python-cryptography: Fix failing build

Fixes https://github.com/openwrt/packages/issues/18876.
Fixes https://github.com/openwrt/packages/issues/18879.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
(cherry picked from commit 9e3b7d7883)
This commit is contained in:
Jeffery To 2022-07-07 17:35:41 +08:00 committed by Rosen Penev
parent 50547b6d51
commit 580926cb6c
2 changed files with 6 additions and 3 deletions

View file

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography PKG_NAME:=python-cryptography
PKG_VERSION:=3.4.8 PKG_VERSION:=3.4.8
PKG_RELEASE:=1 PKG_RELEASE:=2
PYPI_NAME:=cryptography PYPI_NAME:=cryptography
PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c PKG_HASH:=94cc5ed4ceaefcbe5bf38c8fba6a21fc1d365bb8fb826ea1688e3370b2e24a1c

View file

@ -9,9 +9,12 @@
except ImportError: except ImportError:
print( print(
""" """
@@ -45,7 +45,7 @@ setuptools_rust = "setuptools-rust>=0.11 @@ -43,9 +43,9 @@ with open(os.path.join(src_dir, "cryptog
# `pyproject.toml`
setuptools_rust = "setuptools-rust>=0.11.4"
install_requirements = ["cffi>=1.12"] install_requirements = ["cffi>=1.12"]
setup_requirements = install_requirements + [setuptools_rust] -setup_requirements = install_requirements + [setuptools_rust]
+setup_requirements = install_requirements
-if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"): -if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"):
+if True: +if True: