lighttpd: update to 1.4.37
Signed-off-by: W. Michael Petullo <mike@flyn.org>
This commit is contained in:
parent
9cadde2183
commit
57ec0c99a5
2 changed files with 2 additions and 28 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.36
|
||||
PKG_VERSION:=1.4.37
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
|
||||
PKG_MD5SUM:=1843daffcb018aa528f6d15d43544654
|
||||
PKG_MD5SUM:=ca40168f54b46ee29475868ced8507d6
|
||||
|
||||
PKG_LICENSE:=BSD-3c
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
From: =?UTF-8?q?Stefan=20B=C3=BChler?= <stbuehler@web.de>
|
||||
Date: Thu, 13 Aug 2015 18:44:27 +0000
|
||||
Subject: [PATCH] fix out-of-filedescriptors when uploading "large" files
|
||||
(fixes #2660, thx rmilecki)
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
From: Stefan Bühler <stbuehler@web.de>
|
||||
|
||||
git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@3009 152afb58-edef-0310-8abb-c4023f1b3aa9
|
||||
---
|
||||
src/chunk.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/src/chunk.c
|
||||
+++ b/src/chunk.c
|
||||
@@ -432,7 +432,7 @@ static int chunkqueue_append_to_tempfile
|
||||
* */
|
||||
|
||||
if (NULL != dest->last
|
||||
- && FILE_CHUNK != dest->last->type
|
||||
+ && FILE_CHUNK == dest->last->type
|
||||
&& dest->last->file.is_temp
|
||||
&& -1 != dest->last->file.fd
|
||||
&& 0 == dest->last->offset) {
|
Loading…
Reference in a new issue