ipsec-tools: compile with openssl 1.1, compile fix (#6141)
Added compatibility with openssl 1.1, and also fixed a compiler warning about implicit declaration. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
This commit is contained in:
parent
2d79ac1fa3
commit
57c8664b31
3 changed files with 1108 additions and 1 deletions
|
@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=ipsec-tools
|
||||
PKG_VERSION:=0.8.2
|
||||
PKG_RELEASE:=7
|
||||
PKG_RELEASE:=8
|
||||
PKG_MAINTAINER:=Noah Meyerhans <frodo@morgul.net>, \
|
||||
Vitaly Protsko <villy@sft.ru>
|
||||
PKG_LICENSE := BSD-3-Clause
|
||||
|
|
11
net/ipsec-tools/patches/012-fix-implicit-int.patch
Normal file
11
net/ipsec-tools/patches/012-fix-implicit-int.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/racoon/isakmp_xauth.c
|
||||
+++ b/src/racoon/isakmp_xauth.c
|
||||
@@ -376,6 +376,7 @@ xauth_reply(iph1, port, id, res)
|
||||
struct ph1handle *iph1;
|
||||
int port;
|
||||
int id;
|
||||
+ int res;
|
||||
{
|
||||
struct xauth_state *xst = &iph1->mode_cfg->xauth;
|
||||
char *usr = xst->authdata.generic.usr;
|
||||
|
1096
net/ipsec-tools/patches/015-openssl-1.1.patch
Normal file
1096
net/ipsec-tools/patches/015-openssl-1.1.patch
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue