tvheadend: fix compilation with GCC 9 and 10
Without this, compilation fails because of a fortify-source header. There's something defining and undefining _GNU_SOURCE somewhere. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
82edfeb1d0
commit
57c6c5e73f
2 changed files with 10 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tvheadend
|
||||
PKG_VERSION:=4.0.10
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://codeload.github.com/tvheadend/tvheadend/tar.gz/v$(PKG_VERSION)?
|
||||
|
|
9
multimedia/tvheadend/patches/040-fortify.patch
Normal file
9
multimedia/tvheadend/patches/040-fortify.patch
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- a/src/intlconv.c
|
||||
+++ b/src/intlconv.c
|
||||
@@ -1,3 +1,6 @@
|
||||
+#ifndef _GNU_SOURCE
|
||||
+#define _GNU_SOURCE
|
||||
+#endif
|
||||
#include <iconv.h>
|
||||
#include "tvheadend.h"
|
||||
#include "intlconv.h"
|
Loading…
Reference in a new issue