scons: update to 4.0.1
Cleaned up Makefile to standards. Replaced HIDDEN with BUILDONLY. It's more descriptive. Added PKG_HOST_ONLY. This is a host only package. Added HOST_BUILD_PARALLEL. Added URL for uscan. Added patch to fix library searching. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
c4254a3824
commit
572e34843a
3 changed files with 22 additions and 7 deletions
|
@ -8,15 +8,19 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=scons
|
PKG_NAME:=scons
|
||||||
PKG_VERSION:=3.1.2
|
PKG_VERSION:=4.0.1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-local-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-local-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/scons
|
PKG_SOURCE_URL:=@SF/scons
|
||||||
PKG_HASH:=642e90860b746fa18fac08c7a22de6bfa86110ae7c56d7f136f7e5fb0d8f4f44
|
PKG_HASH:=23c9d37a008b525bdedfe2666a28b9466c4c945d8ba379873cfd0b9006a3d618
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=scons-LICENSE
|
PKG_LICENSE_FILES:=scons-LICENSE
|
||||||
PKG_MAINTAINER:=
|
|
||||||
|
PKG_HOST_ONLY:=1
|
||||||
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
@ -27,7 +31,8 @@ define Package/scons
|
||||||
SECTION:=devel
|
SECTION:=devel
|
||||||
CATEGORY:=Development
|
CATEGORY:=Development
|
||||||
TITLE:=scons
|
TITLE:=scons
|
||||||
HIDDEN:=1
|
URL:=https://scons.org/
|
||||||
|
BUILDONLY:=1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/scons/description
|
define Package/scons/description
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/scons-local-3.1.2/SCons/Platform/__init__.py
|
--- a/scons-local-4.0.1/SCons/Platform/__init__.py
|
||||||
+++ b/scons-local-3.1.2/SCons/Platform/__init__.py
|
+++ b/scons-local-4.0.1/SCons/Platform/__init__.py
|
||||||
@@ -65,6 +65,8 @@ def platform_default():
|
@@ -63,6 +63,8 @@ def platform_default():
|
||||||
care about the machine architecture.
|
care about the machine architecture.
|
||||||
"""
|
"""
|
||||||
osname = os.name
|
osname = os.name
|
||||||
|
|
10
devel/scons/patches/002-fix-import-path.patch
Normal file
10
devel/scons/patches/002-fix-import-path.patch
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- a/scons.py
|
||||||
|
+++ b/scons.py
|
||||||
|
@@ -56,6 +56,7 @@ if script_path in sys.path:
|
||||||
|
sys.path.remove(script_path)
|
||||||
|
|
||||||
|
libs = []
|
||||||
|
+libs = [os.path.join(os.path.dirname(script_dir), 'lib', 'scons')]
|
||||||
|
|
||||||
|
if "SCONS_LIB_DIR" in os.environ:
|
||||||
|
libs.append(os.environ["SCONS_LIB_DIR"])
|
Loading…
Reference in a new issue