domoticz: bump to 4.10717
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
(cherry picked from commit 7e50722145
)
This commit is contained in:
parent
8d91ba86a9
commit
572392a8ac
3 changed files with 3 additions and 76 deletions
|
@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=domoticz
|
||||
PKG_VERSION_MAJOR:=4
|
||||
PKG_VERSION_PATCH:=9700
|
||||
PKG_VERSION_PATCH:=10717
|
||||
PKG_COMMIT:=
|
||||
PKG_VERSION:=$(PKG_VERSION_MAJOR).$(PKG_VERSION_PATCH)
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
ifeq ($(PKG_COMMIT),)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -22,7 +22,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_COMMIT).tar.gz
|
|||
PKG_SOURCE_URL:=https://github.com/domoticz/domoticz/archive/$(PKG_COMMIT)/$(PKG_SOURCE)
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_COMMIT)
|
||||
endif
|
||||
PKG_HASH:=c31f185a1ffac01b86a77bf33e059a4403d814e826c9d6639c63c2e9afa55a46
|
||||
PKG_HASH:=c053a2161942529f56b748945ec297dcd67f449e68029fc886893a528891ad86
|
||||
|
||||
PKG_LICENSE:=GPL-3.0
|
||||
PKG_LICENSE_FILES:=License.txt
|
||||
|
|
|
@ -1,71 +0,0 @@
|
|||
From 9d226dab339f5767ec01ea1bcc9043ceee185cca Mon Sep 17 00:00:00 2001
|
||||
From: Rob Peters <info@domoticz.com>
|
||||
Date: Mon, 25 Mar 2019 08:50:23 +0100
|
||||
Subject: [PATCH] Fix for boot 1.70 get_io_service, fixed #3117
|
||||
|
||||
---
|
||||
hardware/Pinger.cpp | 10 ++++++++--
|
||||
hardware/TCPProxy/tcpproxy_server.cpp | 8 +++++++-
|
||||
2 files changed, 15 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/hardware/Pinger.cpp b/hardware/Pinger.cpp
|
||||
index 01a955ba4..184378738 100644
|
||||
--- a/hardware/Pinger.cpp
|
||||
+++ b/hardware/Pinger.cpp
|
||||
@@ -18,6 +18,12 @@
|
||||
|
||||
#include <iostream>
|
||||
|
||||
+#if BOOST_VERSION >= 107000
|
||||
+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
|
||||
+#else
|
||||
+#define GET_IO_SERVICE(s) ((s).get_io_service())
|
||||
+#endif
|
||||
+
|
||||
class pinger
|
||||
: private domoticz::noncopyable
|
||||
{
|
||||
@@ -76,7 +82,7 @@ class pinger
|
||||
num_tries_++;
|
||||
if (num_tries_ > 4)
|
||||
{
|
||||
- resolver_.get_io_service().stop();
|
||||
+ GET_IO_SERVICE(resolver_).stop();
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -118,7 +124,7 @@ class pinger
|
||||
if (num_replies_++ == 0)
|
||||
timer_.cancel();
|
||||
m_PingState = true;
|
||||
- resolver_.get_io_service().stop();
|
||||
+ GET_IO_SERVICE(resolver_).stop();
|
||||
}
|
||||
else
|
||||
{
|
||||
diff --git a/hardware/TCPProxy/tcpproxy_server.cpp b/hardware/TCPProxy/tcpproxy_server.cpp
|
||||
index fddac08de..60445d9c2 100644
|
||||
--- a/hardware/TCPProxy/tcpproxy_server.cpp
|
||||
+++ b/hardware/TCPProxy/tcpproxy_server.cpp
|
||||
@@ -15,6 +15,12 @@
|
||||
#include "stdafx.h"
|
||||
#include "tcpproxy_server.h"
|
||||
|
||||
+#if BOOST_VERSION >= 107000
|
||||
+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
|
||||
+#else
|
||||
+#define GET_IO_SERVICE(s) ((s).get_io_service())
|
||||
+#endif
|
||||
+
|
||||
namespace tcp_proxy
|
||||
{
|
||||
bridge::bridge(boost::asio::io_service& ios)
|
||||
@@ -38,7 +44,7 @@ namespace tcp_proxy
|
||||
boost::asio::ip::tcp::endpoint end;
|
||||
|
||||
|
||||
- boost::asio::io_service &ios=downstream_socket_.get_io_service();
|
||||
+ boost::asio::io_service &ios= GET_IO_SERVICE(downstream_socket_);
|
||||
boost::asio::ip::tcp::resolver resolver(ios);
|
||||
boost::asio::ip::tcp::resolver::query query(upstream_host, upstream_port, boost::asio::ip::resolver_query_base::numeric_service);
|
||||
boost::asio::ip::tcp::resolver::iterator i = resolver.resolve(query);
|
|
@ -8,8 +8,6 @@ OpenSSL has initialization deprecated.
|
|||
main/WebServerHelper.cpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/main/WebServerHelper.cpp b/main/WebServerHelper.cpp
|
||||
index 98ebcf7b4..0a028595c 100644
|
||||
--- a/main/WebServerHelper.cpp
|
||||
+++ b/main/WebServerHelper.cpp
|
||||
@@ -37,7 +37,9 @@ namespace http {
|
||||
|
|
Loading…
Reference in a new issue