From 8bd4b03ef32d6246d5e7279b0f56c7c1e4276f73 Mon Sep 17 00:00:00 2001
From: Jeffery To <jeffery.to@gmail.com>
Date: Fri, 10 Jan 2020 20:40:50 +0800
Subject: [PATCH] asu: Change Python 2 dependencies to Python 3

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
---
 devel/asu/Makefile       | 4 ++--
 devel/asu/files/asu.init | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/devel/asu/Makefile b/devel/asu/Makefile
index 9485ed9d7..a6f0a8ef5 100644
--- a/devel/asu/Makefile
+++ b/devel/asu/Makefile
@@ -23,7 +23,7 @@ IMAGEBUILDER_DEPENDS:= \
     @x86_64 +bash +bzip2 +coreutils +coreutils-stat +diffutils +file \
     +gawk +gcc +getopt +git +git-http +libncurses +make +patch +perl \
     +perlbase-attributes +perlbase-findbin +perlbase-getopt \
-    +perlbase-thread +python-light +tar +unzip +wget +xz +xzdiff \
+    +perlbase-thread +python3-light +tar +unzip +wget +xz +xzdiff \
     +xzgrep +xzless +xz-utils +zlib-dev
 
 define Package/asu
@@ -34,7 +34,7 @@ define Package/asu
     URL:=http://github.com/aparcar/gsoc17-attended-sysupgrade/
     DEPENDS:=$(IMAGEBUILDER_DEPENDS) +pgsql-server +psqlodbcw \
              +python3-ctypes +python3-distutils +python3-flask \
-             +gunicorn +python3-openssl +python3-pyodbc +python3-yaml \
+             +gunicorn3 +python3-openssl +python3-pyodbc +python3-yaml \
              +libustream-mbedtls +ca-certificates +gnupg
     USERID:=asu:asu
     VARIANT:=python3
diff --git a/devel/asu/files/asu.init b/devel/asu/files/asu.init
index 069c0e716..d12221b89 100644
--- a/devel/asu/files/asu.init
+++ b/devel/asu/files/asu.init
@@ -28,7 +28,7 @@ start_service() {
     procd_open_instance asu_main
     procd_set_param user asu
     procd_set_param group asu
-    procd_set_param command gunicorn asu:app
+    procd_set_param command gunicorn3 asu:app
     procd_close_instance
 
     procd_open_instance main_worker