From 7a8481cb4a8c2e9de4eb821f9555ba91e48cc74c Mon Sep 17 00:00:00 2001
From: Adrian Panella <ianchi74@outlook.com>
Date: Tue, 6 Jun 2017 21:34:46 -0500
Subject: [PATCH 1/2] youtube-dl: bump version and use precompiled script

Update to version 2017.06.05
Use precompiled scripts, in line with the new Python package.

Signed-off-by: Adrian Panella <ianchi74@outlook.com>
---
 multimedia/youtube-dl/Makefile | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)

diff --git a/multimedia/youtube-dl/Makefile b/multimedia/youtube-dl/Makefile
index 6433079f9..142c71f3d 100644
--- a/multimedia/youtube-dl/Makefile
+++ b/multimedia/youtube-dl/Makefile
@@ -8,18 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=youtube-dl
-PKG_VERSION:=2017.02.17
+PKG_VERSION:=2017.06.05
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://yt-dl.org/downloads/$(PKG_VERSION)/
-PKG_MD5SUM:=d38dbe099af22eb9af35b0e8b274dc4e
+PKG_MD5SUM:=1f9b35f2c767374967d0afef08132fe2
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 PKG_LICENSE:=Unlicense
 PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>
 
+PKG_BUILD_DEPENDS:=python/host
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -39,7 +40,14 @@ endef
 
 define Package/youtube-dl/install
 	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/youtube-dl $(1)/usr/bin/
+	
+	python -m compileall $(PKG_BUILD_DIR)/youtube_dl/
+	cd $(PKG_BUILD_DIR) && zip --quiet youtube-dl-c.zip youtube_dl/*.pyc youtube_dl/*/*.pyc
+	cd $(PKG_BUILD_DIR) && zip --quiet --junk-paths youtube-dl-c.zip youtube_dl/__main__.pyc
+	echo '#!/usr/bin/env python' > $(PKG_BUILD_DIR)/youtube-dl-c
+	cat $(PKG_BUILD_DIR)/youtube-dl-c.zip >> $(PKG_BUILD_DIR)/youtube-dl-c
+	
+	$(INSTALL_BIN) -T $(PKG_BUILD_DIR)/youtube-dl-c $(1)/usr/bin/youtube-dl
 endef
 
 $(eval $(call BuildPackage,youtube-dl))

From 3d9f812dfa13f8711d7f6686b2722288188b8f33 Mon Sep 17 00:00:00 2001
From: Adrian Panella <ianchi74@outlook.com>
Date: Wed, 7 Jun 2017 08:14:23 -0500
Subject: [PATCH 2/2] youtube-dl: switch from PKG_MD5SUM to PKG_HASH

Signed-off-by: Adrian Panella <ianchi74@outlook.com>
---
 multimedia/youtube-dl/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/multimedia/youtube-dl/Makefile b/multimedia/youtube-dl/Makefile
index 142c71f3d..fc13cb321 100644
--- a/multimedia/youtube-dl/Makefile
+++ b/multimedia/youtube-dl/Makefile
@@ -13,7 +13,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://yt-dl.org/downloads/$(PKG_VERSION)/
-PKG_MD5SUM:=1f9b35f2c767374967d0afef08132fe2
+PKG_HASH:=7ca5143fb2b5d41a9752a4c866cac3f2f261174e
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 PKG_LICENSE:=Unlicense