pcre: upgrade to 0.8.38
fixes: * CVE 2015-2327 CVE 2015-2328 CVE 2015-8380 CVE 2015-8381 CVE * 2015-8382 * CVE 2015-8383 CVE 2015-8384 CVE 2015-8385 CVE 2015-8386 CVE * 2015-8387 * CVE 2015-8388 CVE 2015-8389 CVE 2015-8390 CVE 2015-8391 CVE * 2015-8392 * CVE 2015-8393 CVE 2015-8394 CVE 2015-8395 Signed-off-by: heil <heil@terminal-consulting.de>
This commit is contained in:
parent
bb23089e84
commit
560cb220d2
2 changed files with 4 additions and 36 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=pcre
|
||||
PKG_VERSION:=8.37
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=8.38
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/pcre
|
||||
PKG_MD5SUM:=ed91be292cb01d21bc7e526816c26981
|
||||
PKG_SOURCE_URL:=ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
|
||||
PKG_MD5SUM:=00aabbfe56d5a48b270f999b508c5ad2
|
||||
PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
Index: pcre-8.37/pcre_compile.c
|
||||
===================================================================
|
||||
--- a/pcre_compile.c
|
||||
+++ b/pcre_compile.c
|
||||
@@ -7177,14 +7177,26 @@
|
||||
number. If the name is not found, set the value to 0 for a forward
|
||||
reference. */
|
||||
|
||||
+ recno = 0;
|
||||
ng = cd->named_groups;
|
||||
for (i = 0; i < cd->names_found; i++, ng++)
|
||||
{
|
||||
if (namelen == ng->length &&
|
||||
STRNCMP_UC_UC(name, ng->name, namelen) == 0)
|
||||
- break;
|
||||
+ {
|
||||
+ open_capitem *oc;
|
||||
+ recno = ng->number;
|
||||
+ if (is_recurse) break;
|
||||
+ for (oc = cd->open_caps; oc != NULL; oc = oc->next)
|
||||
+ {
|
||||
+ if (oc->number == recno)
|
||||
+ {
|
||||
+ oc->flag = TRUE;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
- recno = (i < cd->names_found)? ng->number : 0;
|
||||
|
||||
/* Count named back references. */
|
Loading…
Reference in a new issue