libmicrohttpd: update to 0.9.52
Compile tested on x86_64. Runtime tested on x86_64. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
This commit is contained in:
parent
9033f4ba92
commit
55524f1b0a
2 changed files with 2 additions and 16 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libmicrohttpd
|
||||
PKG_VERSION:=0.9.50
|
||||
PKG_VERSION:=0.9.52
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/libmicrohttpd
|
||||
PKG_MD5SUM:=d1b6385068abded29b6470e383287aa7705de05ae3c08ad0bf5747ac4dc6ebd7
|
||||
PKG_MD5SUM:=54797f6e763d417627f89f60e4ae0a431dab0523f92f83def23ea02d0defafea
|
||||
|
||||
PKG_MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
|
||||
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
Index: libmicrohttpd-0.9.50/src/microhttpd/mhd_str.c
|
||||
===================================================================
|
||||
--- libmicrohttpd-0.9.50.orig/src/microhttpd/mhd_str.c 2016-05-02 14:22:44.000000000 +0200
|
||||
+++ libmicrohttpd-0.9.50/src/microhttpd/mhd_str.c 2016-07-15 11:06:39.896282700 +0200
|
||||
@@ -271,7 +271,8 @@
|
||||
int
|
||||
MHD_str_equal_caseless_n_ (const char * const str1, const char * const str2, size_t maxlen)
|
||||
{
|
||||
- for (size_t i = 0; i < maxlen; ++i)
|
||||
+ size_t i;
|
||||
+ for (i = 0; i < maxlen; ++i)
|
||||
{
|
||||
const char c1 = str1[i];
|
||||
const char c2 = str2[i];
|
Loading…
Reference in a new issue