python-pip: Update to 23.3.1, redo/refresh patches
001-pyproject-hooks-pyc-fix.patch and 002-pip-runner-pyc-fix.patch are redone to use source files if they are present. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
2496d74340
commit
548fdba3fd
4 changed files with 18 additions and 8 deletions
|
@ -8,11 +8,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=python-pip
|
||||
PKG_VERSION:=23.2.1
|
||||
PKG_VERSION:=23.3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PYPI_NAME:=pip
|
||||
PKG_HASH:=fb0bd5435b3200c602b5bf61d2d43c2f13c02e29c1707567ae7fbc514eb9faf2
|
||||
PKG_HASH:=1fcaa041308d01f14575f6d0d2ea4b75a3e2871fe4f9c694976f908768e14174
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=LICENSE.txt
|
||||
|
|
|
@ -1,13 +1,19 @@
|
|||
--- a/src/pip/_vendor/pyproject_hooks/_in_process/__init__.py
|
||||
+++ b/src/pip/_vendor/pyproject_hooks/_in_process/__init__.py
|
||||
@@ -11,8 +11,8 @@ try:
|
||||
@@ -11,8 +11,14 @@ try:
|
||||
except AttributeError:
|
||||
# Python 3.8 compatibility
|
||||
def _in_proc_script_path():
|
||||
- return resources.path(__package__, '_in_process.py')
|
||||
+ return resources.path(__package__, '_in_process.pyc')
|
||||
+ filename = '_in_process.pyc'
|
||||
+ if resources.is_resource(__package__, '_in_process.py'):
|
||||
+ filename = '_in_process.py'
|
||||
+ return resources.path(__package__, filename)
|
||||
else:
|
||||
def _in_proc_script_path():
|
||||
+ filename = '_in_process.pyc'
|
||||
+ if resources.files(__package__).joinpath('_in_process.py').is_file():
|
||||
+ filename = '_in_process.py'
|
||||
return resources.as_file(
|
||||
- resources.files(__package__).joinpath('_in_process.py'))
|
||||
+ resources.files(__package__).joinpath('_in_process.pyc'))
|
||||
+ resources.files(__package__).joinpath(filename))
|
||||
|
|
|
@ -1,11 +1,15 @@
|
|||
--- a/src/pip/_internal/build_env.py
|
||||
+++ b/src/pip/_internal/build_env.py
|
||||
@@ -54,7 +54,7 @@ def get_runnable_pip() -> str:
|
||||
@@ -54,7 +54,11 @@ def get_runnable_pip() -> str:
|
||||
# case, we can use that directly.
|
||||
return str(source)
|
||||
|
||||
- return os.fsdecode(source / "__pip-runner__.py")
|
||||
+ return os.fsdecode(source / "__pip-runner__.pyc")
|
||||
+ filename = "__pip-runner__.pyc"
|
||||
+ py = source / "__pip-runner__.py"
|
||||
+ if py.is_file():
|
||||
+ filename = "__pip-runner__.py"
|
||||
+ return os.fsdecode(source / filename)
|
||||
|
||||
|
||||
def _get_system_sitepackages() -> Set[str]:
|
||||
|
|
|
@ -9,7 +9,7 @@ Patch-Name: disable-pip-version-check.patch
|
|||
|
||||
--- a/src/pip/_internal/cli/cmdoptions.py
|
||||
+++ b/src/pip/_internal/cli/cmdoptions.py
|
||||
@@ -892,7 +892,7 @@ disable_pip_version_check: Callable[...,
|
||||
@@ -895,7 +895,7 @@ disable_pip_version_check: Callable[...,
|
||||
"--disable-pip-version-check",
|
||||
dest="disable_pip_version_check",
|
||||
action="store_true",
|
||||
|
|
Loading…
Reference in a new issue