rust: Update to 1.75.0
Changelog: https://blog.rust-lang.org/2023/12/28/Rust-1.75.0.html Refreshed patches. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
9f01010958
commit
546e6eba4f
4 changed files with 15 additions and 43 deletions
|
@ -5,12 +5,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=rust
|
PKG_NAME:=rust
|
||||||
PKG_VERSION:=1.74.0
|
PKG_VERSION:=1.75.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=rustc-$(PKG_VERSION)-src.tar.gz
|
PKG_SOURCE:=rustc-$(PKG_VERSION)-src.tar.gz
|
||||||
PKG_SOURCE_URL:=https://static.rust-lang.org/dist/
|
PKG_SOURCE_URL:=https://static.rust-lang.org/dist/
|
||||||
PKG_HASH:=882b584bc321c5dcfe77cdaa69f277906b936255ef7808fcd5c7492925cf1049
|
PKG_HASH:=5b739f45bc9d341e2d1c570d65d2375591e22c2d23ef5b8a37711a0386abc088
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR)/host/rustc-$(PKG_VERSION)-src
|
HOST_BUILD_DIR:=$(BUILD_DIR)/host/rustc-$(PKG_VERSION)-src
|
||||||
|
|
||||||
PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
|
PKG_MAINTAINER:=Luca Barbato <lu_zero@luminem.org>
|
||||||
|
|
|
@ -11,7 +11,7 @@ Subject: [PATCH] Update xz2 and use it static
|
||||||
|
|
||||||
--- a/src/bootstrap/Cargo.lock
|
--- a/src/bootstrap/Cargo.lock
|
||||||
+++ b/src/bootstrap/Cargo.lock
|
+++ b/src/bootstrap/Cargo.lock
|
||||||
@@ -424,9 +424,9 @@ dependencies = [
|
@@ -391,9 +391,9 @@ dependencies = [
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
name = "lzma-sys"
|
name = "lzma-sys"
|
||||||
|
@ -23,7 +23,7 @@ Subject: [PATCH] Update xz2 and use it static
|
||||||
dependencies = [
|
dependencies = [
|
||||||
"cc",
|
"cc",
|
||||||
"libc",
|
"libc",
|
||||||
@@ -871,9 +871,9 @@ dependencies = [
|
@@ -834,9 +834,9 @@ dependencies = [
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
name = "xz2"
|
name = "xz2"
|
||||||
|
@ -37,12 +37,12 @@ Subject: [PATCH] Update xz2 and use it static
|
||||||
]
|
]
|
||||||
--- a/src/bootstrap/Cargo.toml
|
--- a/src/bootstrap/Cargo.toml
|
||||||
+++ b/src/bootstrap/Cargo.toml
|
+++ b/src/bootstrap/Cargo.toml
|
||||||
@@ -49,7 +49,7 @@ toml = "0.5"
|
@@ -57,7 +57,7 @@ tar = "0.4"
|
||||||
ignore = "0.4.10"
|
termcolor = "1.2.0"
|
||||||
opener = "0.5"
|
toml = "0.5"
|
||||||
once_cell = "1.7.2"
|
walkdir = "2"
|
||||||
-xz2 = "0.1"
|
-xz2 = "0.1"
|
||||||
+xz2 = { version = "0.1", features = ["static"] }
|
+xz2 = { version = "0.1", features = ["static"] }
|
||||||
walkdir = "2"
|
|
||||||
|
|
||||||
# Dependencies needed by the build-metrics feature
|
# Dependencies needed by the build-metrics feature
|
||||||
|
sysinfo = { version = "0.26.0", optional = true }
|
||||||
|
|
|
@ -9,9 +9,9 @@
|
||||||
rustc_cache = os.path.join(cache_dst, key)
|
rustc_cache = os.path.join(cache_dst, key)
|
||||||
if not os.path.exists(rustc_cache):
|
if not os.path.exists(rustc_cache):
|
||||||
os.makedirs(rustc_cache)
|
os.makedirs(rustc_cache)
|
||||||
--- a/src/bootstrap/download.rs
|
--- a/src/bootstrap/src/core/download.rs
|
||||||
+++ b/src/bootstrap/download.rs
|
+++ b/src/bootstrap/src/core/download.rs
|
||||||
@@ -211,7 +211,13 @@ impl Config {
|
@@ -208,7 +208,13 @@ impl Config {
|
||||||
Some(other) => panic!("unsupported protocol {other} in {url}"),
|
Some(other) => panic!("unsupported protocol {other} in {url}"),
|
||||||
None => panic!("no protocol in {url}"),
|
None => panic!("no protocol in {url}"),
|
||||||
}
|
}
|
||||||
|
@ -26,7 +26,7 @@
|
||||||
}
|
}
|
||||||
|
|
||||||
fn download_http_with_retries(&self, tempfile: &Path, url: &str, help_on_error: &str) {
|
fn download_http_with_retries(&self, tempfile: &Path, url: &str, help_on_error: &str) {
|
||||||
@@ -529,7 +535,10 @@ impl Config {
|
@@ -544,7 +550,10 @@ impl Config {
|
||||||
key: &str,
|
key: &str,
|
||||||
destination: &str,
|
destination: &str,
|
||||||
) {
|
) {
|
||||||
|
@ -38,7 +38,7 @@
|
||||||
let cache_dir = cache_dst.join(key);
|
let cache_dir = cache_dst.join(key);
|
||||||
if !cache_dir.exists() {
|
if !cache_dir.exists() {
|
||||||
t!(fs::create_dir_all(&cache_dir));
|
t!(fs::create_dir_all(&cache_dir));
|
||||||
@@ -656,7 +665,10 @@ download-rustc = false
|
@@ -671,7 +680,10 @@ download-rustc = false
|
||||||
let llvm_assertions = self.llvm_assertions;
|
let llvm_assertions = self.llvm_assertions;
|
||||||
|
|
||||||
let cache_prefix = format!("llvm-{llvm_sha}-{llvm_assertions}");
|
let cache_prefix = format!("llvm-{llvm_sha}-{llvm_assertions}");
|
||||||
|
|
|
@ -28,20 +28,6 @@ This patch bumps all libc dependencies and checksums to 0.2.147, which includes
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
name = "libloading"
|
name = "libloading"
|
||||||
--- a/vendor/cranelift-jit/Cargo.lock
|
|
||||||
+++ b/vendor/cranelift-jit/Cargo.lock
|
|
||||||
@@ -224,9 +224,9 @@ dependencies = [
|
|
||||||
|
|
||||||
[[package]]
|
|
||||||
name = "libc"
|
|
||||||
-version = "0.2.141"
|
|
||||||
+version = "0.2.147"
|
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
||||||
-checksum = "3304a64d199bb964be99741b7a14d26972741915b3649639149b2479bb46f4b5"
|
|
||||||
+checksum = "b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3"
|
|
||||||
|
|
||||||
[[package]]
|
|
||||||
name = "log"
|
|
||||||
--- a/vendor/crossbeam-channel/Cargo.lock
|
--- a/vendor/crossbeam-channel/Cargo.lock
|
||||||
+++ b/vendor/crossbeam-channel/Cargo.lock
|
+++ b/vendor/crossbeam-channel/Cargo.lock
|
||||||
@@ -50,9 +50,9 @@ dependencies = [
|
@@ -50,9 +50,9 @@ dependencies = [
|
||||||
|
@ -84,20 +70,6 @@ This patch bumps all libc dependencies and checksums to 0.2.147, which includes
|
||||||
|
|
||||||
[[package]]
|
[[package]]
|
||||||
name = "lock_api"
|
name = "lock_api"
|
||||||
--- a/vendor/icu_locid/Cargo.lock
|
|
||||||
+++ b/vendor/icu_locid/Cargo.lock
|
|
||||||
@@ -318,9 +318,9 @@ checksum = "e2abad23fbc42b3700f2f279844d
|
|
||||||
|
|
||||||
[[package]]
|
|
||||||
name = "libc"
|
|
||||||
-version = "0.2.141"
|
|
||||||
+version = "0.2.147"
|
|
||||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
||||||
-checksum = "3304a64d199bb964be99741b7a14d26972741915b3649639149b2479bb46f4b5"
|
|
||||||
+checksum = "b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3"
|
|
||||||
|
|
||||||
[[package]]
|
|
||||||
name = "litemap"
|
|
||||||
--- a/vendor/libffi/Cargo.lock
|
--- a/vendor/libffi/Cargo.lock
|
||||||
+++ b/vendor/libffi/Cargo.lock
|
+++ b/vendor/libffi/Cargo.lock
|
||||||
@@ -10,9 +10,9 @@ checksum = "50d30906286121d95be3d479533b
|
@@ -10,9 +10,9 @@ checksum = "50d30906286121d95be3d479533b
|
||||||
|
|
Loading…
Reference in a new issue