wget: Update to 1.21.4
Removed upstreamed patches and unneeded autoreconf. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
This commit is contained in:
parent
2227198d74
commit
54593c0ba9
3 changed files with 3 additions and 94 deletions
|
@ -8,19 +8,18 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wget
|
||||
PKG_VERSION:=1.21.3
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.21.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
|
||||
PKG_HASH:=5726bb8bc5ca0f6dc7110f6416e4bb7019e2d2ff5bf93d1ca2ffcc6656f220e5
|
||||
PKG_HASH:=81542f5cefb8faacc39bbbc6c82ded80e3e4a88505ae72ea51df27525bcde04c
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=GPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_CPE_ID:=cpe:/a:gnu:wget
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
From 485217d0ff8d0d17ea3815244b2bc2b747451e15 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Sat, 10 Dec 2022 16:43:38 +0100
|
||||
Subject: [PATCH] * configure.ac: Allow disabling NTLM if nettle present (Savannah #63431)
|
||||
|
||||
---
|
||||
configure.ac | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -648,8 +648,11 @@ else
|
||||
|
||||
if test x"$HAVE_NETTLE" = xyes; then
|
||||
AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
- ENABLE_NTLM=yes
|
||||
- AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
+ if test x"$ENABLE_NTLM" != xno
|
||||
+ then
|
||||
+ ENABLE_NTLM=yes
|
||||
+ AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
+ fi
|
||||
fi
|
||||
fi
|
||||
|
|
@ -1,65 +0,0 @@
|
|||
From c69030a904f8ab25b9ca2704c8a6dd03554e9503 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
|
||||
Date: Sun, 11 Dec 2022 13:31:38 +0100
|
||||
Subject: [PATCH] * configure.ac: Disable nettle if NTLM is explicitly disabled
|
||||
|
||||
---
|
||||
configure.ac | 41 +++++++++++++++++++----------------------
|
||||
1 file changed, 19 insertions(+), 22 deletions(-)
|
||||
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -622,34 +622,31 @@ AS_IF([test x"$with_ssl" = xopenssl], [
|
||||
]) # endif: --with-ssl == openssl?
|
||||
|
||||
dnl Enable NTLM if requested and if SSL is available.
|
||||
-if test x"$LIBSSL" != x || test "$ac_cv_lib_ssl32_SSL_connect" = yes
|
||||
+if test x"$ENABLE_NTLM" != xno
|
||||
then
|
||||
- if test x"$ENABLE_NTLM" != xno
|
||||
+ if test x"$LIBSSL" != x || test "$ac_cv_lib_ssl32_SSL_connect" = yes
|
||||
then
|
||||
ENABLE_NTLM=yes
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
- fi
|
||||
-else
|
||||
- PKG_CHECK_MODULES([NETTLE], nettle, [
|
||||
- HAVE_NETTLE=yes
|
||||
- LIBS="$NETTLE_LIBS $LIBS"
|
||||
- CFLAGS="$NETTLE_CFLAGS $CFLAGS"
|
||||
- ], [
|
||||
- AC_CHECK_LIB(nettle, nettle_md4_init, [HAVE_NETTLE=yes], [HAVE_NETTLE=no; AC_MSG_WARN(*** libnettle was not found. You will not be able to use NTLM)])
|
||||
- if test x"$HAVE_NETTLE" != xyes; then
|
||||
- if test x"$ENABLE_NTLM" = xyes; then
|
||||
- AC_MSG_ERROR([NTLM authorization requested and SSL not enabled; aborting])
|
||||
- fi
|
||||
- else
|
||||
- AC_SUBST(NETTLE_LIBS, "-lnettle")
|
||||
+ else
|
||||
+ PKG_CHECK_MODULES([NETTLE], nettle, [
|
||||
+ HAVE_NETTLE=yes
|
||||
LIBS="$NETTLE_LIBS $LIBS"
|
||||
- fi
|
||||
- ])
|
||||
+ CFLAGS="$NETTLE_CFLAGS $CFLAGS"
|
||||
+ ], [
|
||||
+ AC_CHECK_LIB(nettle, nettle_md4_init, [HAVE_NETTLE=yes], [HAVE_NETTLE=no; AC_MSG_WARN(*** libnettle was not found. You will not be able to use NTLM)])
|
||||
+ if test x"$HAVE_NETTLE" != xyes; then
|
||||
+ if test x"$ENABLE_NTLM" = xyes; then
|
||||
+ AC_MSG_ERROR([NTLM authorization requested and SSL not enabled; aborting])
|
||||
+ fi
|
||||
+ else
|
||||
+ AC_SUBST(NETTLE_LIBS, "-lnettle")
|
||||
+ LIBS="$NETTLE_LIBS $LIBS"
|
||||
+ fi
|
||||
+ ])
|
||||
|
||||
- if test x"$HAVE_NETTLE" = xyes; then
|
||||
- AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
- if test x"$ENABLE_NTLM" != xno
|
||||
- then
|
||||
+ if test x"$HAVE_NETTLE" = xyes; then
|
||||
+ AC_DEFINE([HAVE_NETTLE], [1], [Use libnettle])
|
||||
ENABLE_NTLM=yes
|
||||
AC_DEFINE([ENABLE_NTLM], 1, [Define if you want the NTLM authorization support compiled in.])
|
||||
fi
|
Loading…
Reference in a new issue