seafile-server: Update to 6.3.4
Switched to codeload for simplicity and easier package bumping. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
7e36a24dd3
commit
543f4a5c47
7 changed files with 44 additions and 59 deletions
|
@ -8,16 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=seafile-server
|
PKG_NAME:=seafile-server
|
||||||
PKG_VERSION:=6.3.0
|
PKG_VERSION:=6.3.4
|
||||||
PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
|
PKG_RELEASE:=1
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://github.com/haiwen/seafile-server.git
|
PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seafile-server/tar.gz/v$(PKG_VERSION)-server?
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_HASH:=1ba4c641bad8d7592fd2592827e81470c88b8e802707d2b1e6d551c16d0da100
|
||||||
PKG_SOURCE_VERSION:=a8c66e1bc6f6245e48917f39a24167d22a95dbd6
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-server
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
|
||||||
PKG_MIRROR_HASH:=d63667f8cddcac645fb0d350c71e2a32d0c44f47df46a3a013d2dbecb3574d9a
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
@ -30,11 +29,11 @@ define Package/seafile-server
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
TITLE:=Seafile server
|
TITLE:=Seafile server
|
||||||
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
|
||||||
URL:=http://seafile.com/
|
URL:=https://seafile.com/
|
||||||
DEPENDS:=+libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub +sqlite3-cli +python-mysql +python-urllib3 \
|
DEPENDS:=+libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub +sqlite3-cli +python-mysql +python-urllib3 \
|
||||||
+jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient \
|
+jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 +libmysqlclient \
|
||||||
+libpthread +libuuid +bash +procps-ng +procps-ng-pkill +SEAFILE_FUSE_SUPPORT:libfuse $(ICONV_DEPENDS)
|
+libpthread +libuuid +bash +procps-ng +procps-ng-pkill +SEAFILE_FUSE_SUPPORT:libfuse $(ICONV_DEPENDS)
|
||||||
EXTRA_DEPENDS:=seafile-seahub (=6.3.0-d1ab146a936a6ea1e1581bf3f194e86742f0d3cd-1)
|
EXTRA_DEPENDS:=seafile-seahub (=6.3.4-1)
|
||||||
MENU:=1
|
MENU:=1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
|
|
@ -1,6 +1,5 @@
|
||||||
diff -rupN seafile-server-5.1.1.orig/controller/seafile-controller.c seafile-server-5.1.1/controller/seafile-controller.c
|
--- a/controller/seafile-controller.c
|
||||||
--- seafile-server-5.1.1.orig/controller/seafile-controller.c 2016-04-19 15:44:32.000000000 +0200
|
+++ b/controller/seafile-controller.c
|
||||||
+++ seafile-server-5.1.1/controller/seafile-controller.c 2016-04-19 16:23:05.785000218 +0200
|
|
||||||
@@ -21,7 +21,7 @@
|
@@ -21,7 +21,7 @@
|
||||||
|
|
||||||
SeafileController *ctl;
|
SeafileController *ctl;
|
||||||
|
@ -10,7 +9,7 @@ diff -rupN seafile-server-5.1.1.orig/controller/seafile-controller.c seafile-ser
|
||||||
|
|
||||||
char *bin_dir = NULL;
|
char *bin_dir = NULL;
|
||||||
char *installpath = NULL;
|
char *installpath = NULL;
|
||||||
@@ -575,9 +575,9 @@ stop_ccnet_server ()
|
@@ -591,9 +591,9 @@ stop_ccnet_server ()
|
||||||
static void
|
static void
|
||||||
init_pidfile_path (SeafileController *ctl)
|
init_pidfile_path (SeafileController *ctl)
|
||||||
{
|
{
|
||||||
|
|
|
@ -1,6 +1,5 @@
|
||||||
diff -rupN seafile-server-5.1.1.orig/tools/seafile-admin seafile-server-5.1.1/tools/seafile-admin
|
--- a/tools/seafile-admin
|
||||||
--- seafile-server-5.1.1.orig/tools/seafile-admin 2016-04-19 15:44:33.000000000 +0200
|
+++ b/tools/seafile-admin
|
||||||
+++ seafile-server-5.1.1/tools/seafile-admin 2016-04-26 10:55:11.826798430 +0200
|
|
||||||
@@ -449,9 +449,12 @@ workers = 3
|
@@ -449,9 +449,12 @@ workers = 3
|
||||||
|
|
||||||
# Logging
|
# Logging
|
||||||
|
|
|
@ -1,13 +1,12 @@
|
||||||
diff -rupN seafile-server-5.1.1.orig/lib/Makefile.am seafile-server-5.1.1/lib/Makefile.am
|
--- a/lib/Makefile.am
|
||||||
--- seafile-server-5.1.1.orig/lib/Makefile.am 2016-04-21 11:05:26.000000000 +0200
|
+++ b/lib/Makefile.am
|
||||||
+++ seafile-server-5.1.1/lib/Makefile.am 2016-04-22 10:09:41.567751561 +0200
|
|
||||||
@@ -1,3 +1,5 @@
|
@@ -1,3 +1,5 @@
|
||||||
+include $(TOPDIR)/rules.mk
|
+include $(TOPDIR)/rules.mk
|
||||||
+
|
+
|
||||||
pcfiles = libseafile.pc
|
pcfiles = libseafile.pc
|
||||||
pkgconfig_DATA = $(pcfiles)
|
pkgconfig_DATA = $(pcfiles)
|
||||||
pkgconfigdir = $(libdir)/pkgconfig
|
pkgconfigdir = $(libdir)/pkgconfig
|
||||||
@@ -35,7 +37,7 @@ seafile-rpc-wrapper.c: seafile-object.h
|
@@ -33,7 +35,7 @@ seafile_HEADERS = seafile-object.h
|
||||||
|
|
||||||
seafile-object.h: ${seafile_object_define}
|
seafile-object.h: ${seafile_object_define}
|
||||||
rm -f $@
|
rm -f $@
|
||||||
|
@ -16,7 +15,7 @@ diff -rupN seafile-server-5.1.1.orig/lib/Makefile.am seafile-server-5.1.1/lib/Ma
|
||||||
|
|
||||||
DISTCLEANFILES = ${searpc_gen}
|
DISTCLEANFILES = ${searpc_gen}
|
||||||
|
|
||||||
@@ -64,7 +66,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_t
|
@@ -56,7 +58,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_table.py
|
||||||
@rm -f rpc_table.tmp
|
@rm -f rpc_table.tmp
|
||||||
@touch rpc_table.tmp
|
@touch rpc_table.tmp
|
||||||
@echo "[libsearpc]: generating rpc header files"
|
@echo "[libsearpc]: generating rpc header files"
|
||||||
|
@ -25,7 +24,7 @@ diff -rupN seafile-server-5.1.1.orig/lib/Makefile.am seafile-server-5.1.1/lib/Ma
|
||||||
@echo "[libsearpc]: done"
|
@echo "[libsearpc]: done"
|
||||||
@mv -f rpc_table.tmp $@
|
@mv -f rpc_table.tmp $@
|
||||||
|
|
||||||
@@ -74,7 +76,7 @@ vala.stamp: ${seafile_object_define}
|
@@ -66,7 +68,7 @@ vala.stamp: ${seafile_object_define}
|
||||||
rm -f ${seafile_object_gen}
|
rm -f ${seafile_object_gen}
|
||||||
@rm -f vala.tmp
|
@rm -f vala.tmp
|
||||||
@touch vala.tmp
|
@touch vala.tmp
|
||||||
|
@ -34,7 +33,7 @@ diff -rupN seafile-server-5.1.1.orig/lib/Makefile.am seafile-server-5.1.1/lib/Ma
|
||||||
@mv -f vala.tmp $@
|
@mv -f vala.tmp $@
|
||||||
|
|
||||||
${seafile_object_gen}: vala.stamp
|
${seafile_object_gen}: vala.stamp
|
||||||
@@ -90,5 +92,5 @@ install-data-local:
|
@@ -82,5 +84,5 @@ install-data-local:
|
||||||
if MACOS
|
if MACOS
|
||||||
sed -i '' -e "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
|
sed -i '' -e "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
|
||||||
else
|
else
|
||||||
|
|
|
@ -1,6 +1,5 @@
|
||||||
diff -rupN seafile-server-5.1.1.orig/scripts/seaf-fuse.sh seafile-server-5.1.1/scripts/seaf-fuse.sh
|
--- a/scripts/seaf-fuse.sh
|
||||||
--- seafile-server-5.1.1.orig/scripts/seaf-fuse.sh 2016-05-29 08:43:19.000000000 +0200
|
+++ b/scripts/seaf-fuse.sh
|
||||||
+++ seafile-server-5.1.1/scripts/seaf-fuse.sh 2016-05-29 09:13:06.286680653 +0200
|
|
||||||
@@ -7,7 +7,7 @@ INSTALLPATH=$(dirname "${SCRIPT}")
|
@@ -7,7 +7,7 @@ INSTALLPATH=$(dirname "${SCRIPT}")
|
||||||
TOPDIR=$(dirname "${INSTALLPATH}")
|
TOPDIR=$(dirname "${INSTALLPATH}")
|
||||||
default_ccnet_conf_dir=${TOPDIR}/ccnet
|
default_ccnet_conf_dir=${TOPDIR}/ccnet
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
From 25dcf165f77c94f758383d35632293d69666d0ad Mon Sep 17 00:00:00 2001
|
|
||||||
From: cuihaikuo <haikuo.cui@seafile.com>
|
|
||||||
Date: Thu, 7 Jun 2018 11:56:44 +0800
|
|
||||||
Subject: [PATCH] Fix that table SystemInfo can't be created in sqlite db.
|
|
||||||
|
|
||||||
---
|
|
||||||
server/seafile-session.c | 10 +++++++++-
|
|
||||||
1 file changed, 9 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/server/seafile-session.c b/server/seafile-session.c
|
|
||||||
index 76d9c12..2a1fc0c 100644
|
|
||||||
--- a/server/seafile-session.c
|
|
||||||
+++ b/server/seafile-session.c
|
|
||||||
@@ -424,9 +424,17 @@ create_system_default_repo (void *data)
|
|
||||||
void
|
|
||||||
schedule_create_system_default_repo (SeafileSession *session)
|
|
||||||
{
|
|
||||||
- char *sql = "CREATE TABLE IF NOT EXISTS SystemInfo "
|
|
||||||
+ int db_type = seaf_db_type (session->db);
|
|
||||||
+ char *sql;
|
|
||||||
+
|
|
||||||
+ if (db_type == SEAF_DB_TYPE_MYSQL)
|
|
||||||
+ sql = "CREATE TABLE IF NOT EXISTS SystemInfo "
|
|
||||||
"(id BIGINT NOT NULL PRIMARY KEY AUTO_INCREMENT, "
|
|
||||||
"info_key VARCHAR(256), info_value VARCHAR(1024))";
|
|
||||||
+ else
|
|
||||||
+ sql = "CREATE TABLE IF NOT EXISTS SystemInfo( "
|
|
||||||
+ "info_key VARCHAR(256), info_value VARCHAR(1024))";
|
|
||||||
+
|
|
||||||
if (seaf_db_query (session->db, sql) < 0)
|
|
||||||
return;
|
|
||||||
|
|
22
net/seafile-server/patches/090-django-11-compat.patch
Normal file
22
net/seafile-server/patches/090-django-11-compat.patch
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
diff --git a/tools/seafile-admin b/tools/seafile-admin
|
||||||
|
index 495ceab..72b6a07 100755
|
||||||
|
--- a/tools/seafile-admin
|
||||||
|
+++ b/tools/seafile-admin
|
||||||
|
@@ -502,7 +502,7 @@ def init_seahub():
|
||||||
|
# create seahub_settings.py
|
||||||
|
create_seahub_settings_py()
|
||||||
|
|
||||||
|
- argv = [PYTHON, 'manage.py', 'syncdb']
|
||||||
|
+ argv = [PYTHON, 'manage.py', 'migrate']
|
||||||
|
# Set proper PYTHONPATH before run django syncdb command
|
||||||
|
env = get_seahub_env()
|
||||||
|
|
||||||
|
@@ -512,7 +512,7 @@ def init_seahub():
|
||||||
|
print
|
||||||
|
|
||||||
|
if run_argv(argv, cwd=seahub_dir, env=env) != 0:
|
||||||
|
- error('Seahub syncdb failed')
|
||||||
|
+ error('Seahub migrate failed')
|
||||||
|
|
||||||
|
info('done')
|
||||||
|
|
Loading…
Reference in a new issue