postgresql: security update to version 11.14
Patch 001-configure_fixes does not apply anymore. Other patches were refreshed. Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
This commit is contained in:
parent
b7d2b9163c
commit
535f4804b6
4 changed files with 15 additions and 56 deletions
|
@ -5,7 +5,7 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postgresql
|
||||
PKG_VERSION:=11.3
|
||||
PKG_VERSION:=11.14
|
||||
PKG_RELEASE:=1
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=PostgreSQL
|
||||
|
@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
|
|||
http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
|
||||
ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
|
||||
|
||||
PKG_HASH:=2a85e082fc225944821dfd23990e32dfcd2284c19060864b0ad4ca537d30522d
|
||||
PKG_HASH:=965c7f4be96fb64f9581852c58c4f05c3812d4ad823c0f3e2bdfe777c162f999
|
||||
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
diff --git a/configure.in b/configure.in
|
||||
index 9082c5b..2c04edc 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -2283,36 +2283,6 @@ if test "$with_python" = yes; then
|
||||
CPPFLAGS=$ac_save_CPPFLAGS
|
||||
fi
|
||||
|
||||
-#
|
||||
-# Check for DocBook and tools
|
||||
-#
|
||||
-PGAC_PATH_XMLLINT
|
||||
-PGAC_CHECK_DOCBOOK(4.2)
|
||||
-PGAC_PATH_PROGS(DBTOEPUB, dbtoepub)
|
||||
-PGAC_PATH_PROGS(XSLTPROC, xsltproc)
|
||||
-PGAC_PATH_PROGS(FOP, fop)
|
||||
-
|
||||
-#
|
||||
-# Check for test tools
|
||||
-#
|
||||
-if test "$enable_tap_tests" = yes; then
|
||||
- # Check for necessary modules, unless user has specified the "prove" to use;
|
||||
- # in that case it's her responsibility to have a working configuration.
|
||||
- # (prove might be part of a different Perl installation than perl, eg on
|
||||
- # MSys, so the result of AX_PROG_PERL_MODULES could be irrelevant anyway.)
|
||||
- if test -z "$PROVE"; then
|
||||
- # Test::More and Time::HiRes are supposed to be part of core Perl,
|
||||
- # but some distros omit them in a minimal installation.
|
||||
- AX_PROG_PERL_MODULES([IPC::Run Test::More=0.87 Time::HiRes], ,
|
||||
- [AC_MSG_ERROR([Additional Perl modules are required to run TAP tests])])
|
||||
- fi
|
||||
- # Now make sure we know where prove is
|
||||
- PGAC_PATH_PROGS(PROVE, prove)
|
||||
- if test -z "$PROVE"; then
|
||||
- AC_MSG_ERROR([prove not found])
|
||||
- fi
|
||||
-fi
|
||||
-
|
||||
# Thread testing
|
||||
|
||||
# We have to run the thread test near the end so we have all our symbols
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/port/Makefile
|
||||
+++ b/src/port/Makefile
|
||||
@@ -53,6 +53,7 @@ uninstall:
|
||||
@@ -57,6 +57,7 @@ uninstall:
|
||||
libpgport.a: $(OBJS)
|
||||
rm -f $@
|
||||
$(AR) $(AROPT) $@ $^
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
--- a/src/bin/pg_ctl/pg_ctl.c
|
||||
+++ b/src/bin/pg_ctl/pg_ctl.c
|
||||
@@ -88,6 +88,7 @@ static char *event_source = NULL;
|
||||
static char *register_servicename = "PostgreSQL"; /* FIXME: + version ID? */
|
||||
@@ -91,6 +91,7 @@ static char *event_source = NULL;
|
||||
static char *register_servicename = "PostgreSQL"; /* FIXME: + version ID? */
|
||||
static char *register_username = NULL;
|
||||
static char *register_password = NULL;
|
||||
+static char *username = "";
|
||||
static char *argv0 = NULL;
|
||||
static bool allow_core_files = false;
|
||||
static time_t start_time;
|
||||
@@ -1930,6 +1931,9 @@ do_help(void)
|
||||
@@ -1935,6 +1936,9 @@ do_help(void)
|
||||
#endif
|
||||
printf(_(" -s, --silent only print errors, no informational messages\n"));
|
||||
printf(_(" -t, --timeout=SECS seconds to wait when using -w option\n"));
|
||||
|
@ -16,17 +16,17 @@
|
|||
+ printf(_(" -U, --username=NAME user name of account PostgreSQL server is running as\n"));
|
||||
+#endif
|
||||
printf(_(" -V, --version output version information, then exit\n"));
|
||||
printf(_(" -w wait until operation completes\n"));
|
||||
printf(_(" -W do not wait until operation completes\n"));
|
||||
@@ -2126,6 +2130,7 @@ main(int argc, char **argv)
|
||||
{"pgdata", required_argument, NULL, 'D'},
|
||||
printf(_(" -w, --wait wait until operation completes (default)\n"));
|
||||
printf(_(" -W, --no-wait do not wait until operation completes\n"));
|
||||
@@ -2147,6 +2151,7 @@ main(int argc, char **argv)
|
||||
{"options", required_argument, NULL, 'o'},
|
||||
{"silent", no_argument, NULL, 's'},
|
||||
{"timeout", required_argument, NULL, 't'},
|
||||
+ {"username", required_argument, NULL, 'U'},
|
||||
{"core-files", no_argument, NULL, 'c'},
|
||||
{NULL, 0, NULL, 0}
|
||||
};
|
||||
@@ -2166,20 +2171,6 @@ main(int argc, char **argv)
|
||||
{"wait", no_argument, NULL, 'w'},
|
||||
{"no-wait", no_argument, NULL, 'W'},
|
||||
@@ -2190,20 +2195,6 @@ main(int argc, char **argv)
|
||||
}
|
||||
}
|
||||
|
||||
|
@ -47,7 +47,7 @@
|
|||
|
||||
env_wait = getenv("PGCTLTIMEOUT");
|
||||
if (env_wait != NULL)
|
||||
@@ -2265,11 +2256,15 @@ main(int argc, char **argv)
|
||||
@@ -2290,11 +2281,15 @@ main(int argc, char **argv)
|
||||
wait_seconds_arg = true;
|
||||
break;
|
||||
case 'U':
|
||||
|
@ -63,7 +63,7 @@
|
|||
break;
|
||||
case 'w':
|
||||
do_wait = true;
|
||||
@@ -2351,6 +2346,41 @@ main(int argc, char **argv)
|
||||
@@ -2374,6 +2369,41 @@ main(int argc, char **argv)
|
||||
exit(1);
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue