From 8d4b700597870d2ca00bcf22b43a069453b3c211 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Mon, 17 Sep 2018 15:04:03 -0700
Subject: [PATCH] libsearpc: Update to 3.1.0

Switch to codeload for simplicity. Rearranged Makefile a bit for consistency between Makefiles.

Removed version dependency for seafile-server to avoid breaking builds.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 libs/libsearpc/Makefile    | 21 +++++++++++----------
 net/seafile-ccnet/Makefile |  1 -
 2 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index e2ed5806a..d29838b55 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -8,17 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsearpc
-PKG_VERSION:=3.0.8
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
-PKG_LICENSE:=GPL-3.0
+PKG_VERSION:=3.1.0
+PKG_RELEASE=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/haiwen/libsearpc/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=cbd86d3c37b54ca2060ca537a07940fe3e98498abf345b2f3e1cec488230231a
+
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=LICENSE.txt
 
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=12a01268825e9c7e17794c58c367e3b4db912ad9
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-PKG_MIRROR_HASH:=8ca4785c4d276afeac212a26a143b22e45b85cf196c1218e4630f6072a33f430
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -30,7 +31,7 @@ define Package/libsearpc
     CATEGORY:=Libraries
     TITLE:=Seafile RPC Library
     MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
-    URL:=http://seafile.com/
+    URL:=https://seafile.com
     DEPENDS:=+glib2 +jansson +python $(ICONV_DEPENDS)
 endef
 
diff --git a/net/seafile-ccnet/Makefile b/net/seafile-ccnet/Makefile
index beda03459..5fea11356 100644
--- a/net/seafile-ccnet/Makefile
+++ b/net/seafile-ccnet/Makefile
@@ -34,7 +34,6 @@ define Package/seafile-ccnet
     DEPENDS:=+libsearpc +libevent2 +libopenssl \
 		+glib2 +python +libzdb +libuuid \
 		+libpthread +libsqlite3 +jansson $(ICONV_DEPENDS)
-    EXTRA_DEPENDS:=libsearpc (=3.0.8-12a01268825e9c7e17794c58c367e3b4db912ad9-1)
 endef
 
 define Package/seafile-ccnet/description