shairplay: update to latest version
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
cf18ddf0a2
commit
52e2f0e80b
2 changed files with 6 additions and 19 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2015 OpenWrt.org
|
||||
# Copyright (C) 2014-2015 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shairplay
|
||||
PKG_VERSION:=2014-10-27
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2015-09-29
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_URL:=git://github.com/juhovh/shairplay.git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=64d59e3087f829006d091fa0d114efb50972a2bf
|
||||
PKG_SOURCE_VERSION:=498bc5bcdd305e04721f94a04b9f26a7da72673f
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||
|
||||
|
|
|
@ -1,24 +1,11 @@
|
|||
--- a/src/lib/alac/alac.c
|
||||
+++ b/src/lib/alac/alac.c
|
||||
@@ -29,11 +29,7 @@
|
||||
@@ -29,7 +29,7 @@
|
||||
*
|
||||
*/
|
||||
|
||||
-#ifdef __BIG_ENDIAN__
|
||||
-static const int host_bigendian = 1;
|
||||
-#else
|
||||
-static const int host_bigendian = 0;
|
||||
-#endif
|
||||
+static int host_bigendian = 0;
|
||||
+#define host_bigendian (htonl(42) == 42)
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
@@ -1181,6 +1177,8 @@ alac_file *create_alac(int samplesize, i
|
||||
{
|
||||
alac_file *newfile = malloc(sizeof(alac_file));
|
||||
|
||||
+ host_bigendian = (htonl(42) == 42);
|
||||
+
|
||||
newfile->samplesize = samplesize;
|
||||
newfile->numchannels = numchannels;
|
||||
newfile->bytespersample = (samplesize / 8) * numchannels;
|
||||
|
|
Loading…
Reference in a new issue