Merge pull request #663 from luizluca/libvpx_issue662
libvpx: force to use gcc as linker
This commit is contained in:
commit
527539c842
2 changed files with 7 additions and 15 deletions
|
@ -23,7 +23,6 @@ PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
||||||
#PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -55,9 +54,14 @@ ifneq ($(findstring -Os,$(TARGET_CFLAGS)),)
|
||||||
CONFIGURE_ARGS += --enable-small
|
CONFIGURE_ARGS += --enable-small
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
# libvpx expects gcc as linker but uses $LD if provided
|
||||||
|
# However, OpenWRT defines LD as *-uclibc-ld and not *-gcc
|
||||||
CONFIGURE_VARS += \
|
CONFIGURE_VARS += \
|
||||||
CROSS=$(GNU_TARGET_NAME)\
|
CROSS=$(GNU_TARGET_NAME) \
|
||||||
extralibs="-lc -lgcc_s"
|
LD="$(TARGET_CC)" \
|
||||||
|
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
LD="$(TARGET_CC)" \
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include/vpx/
|
$(INSTALL_DIR) $(1)/usr/include/vpx/
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- libvpx-1.3.0/build/make/Makefile.old 2014-12-06 02:17:06.648714353 -0200
|
|
||||||
+++ libvpx-1.3.0/build/make/Makefile 2014-12-06 02:17:16.096555499 -0200
|
|
||||||
@@ -268,8 +268,8 @@
|
|
||||||
$(1):
|
|
||||||
$(if $(quiet),@echo " [LD] $$@")
|
|
||||||
$(qexec)$$(LD) -shared $$(LDFLAGS) \
|
|
||||||
- -Wl,--no-undefined -Wl,-soname,$$(SONAME) \
|
|
||||||
- -Wl,--version-script,$$(EXPORTS_FILE) -o $$@ \
|
|
||||||
+ --no-undefined -soname $$(SONAME) \
|
|
||||||
+ --version-script $$(EXPORTS_FILE) -o $$@ \
|
|
||||||
$$(filter %.o,$$^) $$(extralibs)
|
|
||||||
endef
|
|
Loading…
Reference in a new issue