dovecot: Fix compilation for OpenSSL without deprecated APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
e39273533d
commit
5226c0bfe9
2 changed files with 27 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=dovecot
|
||||
PKG_VERSION:=2.3.2.1
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://www.dovecot.org/releases/2.3
|
||||
|
|
26
mail/dovecot/patches/100-openssl-deprecated.patch
Normal file
26
mail/dovecot/patches/100-openssl-deprecated.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff --git a/src/lib-dcrypt/dcrypt-openssl.c b/src/lib-dcrypt/dcrypt-openssl.c
|
||||
index c2dbd30..201ab40 100644
|
||||
--- a/src/lib-dcrypt/dcrypt-openssl.c
|
||||
+++ b/src/lib-dcrypt/dcrypt-openssl.c
|
||||
@@ -20,6 +20,7 @@
|
||||
#include <openssl/engine.h>
|
||||
#include <openssl/hmac.h>
|
||||
#include <openssl/objects.h>
|
||||
+#include <openssl/bn.h>
|
||||
#include "dcrypt.h"
|
||||
#include "dcrypt-private.h"
|
||||
|
||||
diff --git a/src/lib-ssl-iostream/iostream-openssl-context.c b/src/lib-ssl-iostream/iostream-openssl-context.c
|
||||
index e3c902e..ad6a9c1 100644
|
||||
--- a/src/lib-ssl-iostream/iostream-openssl-context.c
|
||||
+++ b/src/lib-ssl-iostream/iostream-openssl-context.c
|
||||
@@ -6,6 +6,9 @@
|
||||
#include "dovecot-openssl-common.h"
|
||||
|
||||
#include <openssl/crypto.h>
|
||||
+#include <openssl/rsa.h>
|
||||
+#include <openssl/dh.h>
|
||||
+#include <openssl/bn.h>
|
||||
#include <openssl/x509.h>
|
||||
#include <openssl/pem.h>
|
||||
#include <openssl/ssl.h>
|
Loading…
Reference in a new issue