libimobiledevice: Update to latest master
Added patch to fix Wformat warning. Fixed license information. Removed outdated iconv dependency Placed in a submenu for readability. Added myself as maintainer. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
31fb078125
commit
517005ca51
2 changed files with 82 additions and 10 deletions
|
@ -8,28 +8,28 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libimobiledevice
|
PKG_NAME:=libimobiledevice
|
||||||
PKG_SOURCE_DATE:=2019-11-29
|
PKG_SOURCE_DATE:=2019-12-16
|
||||||
PKG_SOURCE_VERSION:=9f79242a441ce37c28db2b84d49621d26418dc53
|
PKG_SOURCE_VERSION:=d04f8ff2e20c42f74161c9cd66502da17b8b0e70
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_MAINTAINER:=
|
|
||||||
PKG_LICENSE:=LGPL-2.1-or-later
|
|
||||||
PKG_LICENSE_FILES:=COPYING.LESSER
|
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/libimobiledevice/libimobiledevice
|
PKG_SOURCE_URL:=https://github.com/libimobiledevice/libimobiledevice
|
||||||
PKG_MIRROR_HASH:=709a3f8632930be272020a2ff5109aab5a6dddda39580d60e4f5eacace857e08
|
PKG_MIRROR_HASH:=f3ea7b5cd9789dc23ddc464bd00f39813116239cfe4ea1f13f58ce5a8413c361
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
|
||||||
|
PKG_LICENSE:=LGPL-2.1-or-later
|
||||||
|
PKG_LICENSE_FILES:=COPYING.LESSER
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
|
||||||
|
|
||||||
define Package/libimobiledevice/Default
|
define Package/libimobiledevice/Default
|
||||||
TITLE:=A library that talks to Apple devices.
|
TITLE:=A library that talks to Apple devices.
|
||||||
URL:=https://www.libimobiledevice.org/
|
URL:=https://www.libimobiledevice.org/
|
||||||
|
SUBMENU:=libimobiledevice
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libimobiledevice/Default/description
|
define Package/libimobiledevice/Default/description
|
||||||
|
@ -41,7 +41,9 @@ define Package/libimobiledevice
|
||||||
$(call Package/libimobiledevice/Default)
|
$(call Package/libimobiledevice/Default)
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
DEPENDS:=$(ICONV_DEPENDS) +libplist +libusbmuxd +libopenssl
|
DEPENDS:=+libplist +libusbmuxd +libopenssl
|
||||||
|
LICENSE:=LGPL-2.1-or-later
|
||||||
|
LICENSE_FILES:=COPYING.LESSER
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libimobiledevice/description
|
define Package/libimobiledevice/description
|
||||||
|
@ -53,6 +55,8 @@ define Package/libimobiledevice-utils
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+libimobiledevice
|
DEPENDS:=+libimobiledevice
|
||||||
|
LICENSE:=GPL-2.0-or-later
|
||||||
|
ICENSE_FILES:=COPYING
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libimobiledevice-utils/description
|
define Package/libimobiledevice-utils/description
|
||||||
|
@ -60,7 +64,6 @@ define Package/libimobiledevice-utils/description
|
||||||
This package contains the libimobiledevice utilities.
|
This package contains the libimobiledevice utilities.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_VARS += ac_cv_sys_file_offset_bits=64
|
|
||||||
CONFIGURE_ARGS += --without-cython
|
CONFIGURE_ARGS += --without-cython
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
|
|
69
libs/libimobiledevice/patches/010-format.patch
Normal file
69
libs/libimobiledevice/patches/010-format.patch
Normal file
|
@ -0,0 +1,69 @@
|
||||||
|
From ec2bba4ffe5a0939ba192b014ba594eaa964412f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Rosen Penev <rosenp@gmail.com>
|
||||||
|
Date: Sun, 8 Dec 2019 15:45:19 -0800
|
||||||
|
Subject: [PATCH] idevicedate: Fix -Wformat=2 warning
|
||||||
|
|
||||||
|
Format functions expect a constant expression, not a variable.
|
||||||
|
|
||||||
|
Simplified the code slightly.
|
||||||
|
---
|
||||||
|
tools/idevicedate.c | 17 ++++-------------
|
||||||
|
1 file changed, 4 insertions(+), 13 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/tools/idevicedate.c b/tools/idevicedate.c
|
||||||
|
index 4de90b63..6dddc185 100644
|
||||||
|
--- a/tools/idevicedate.c
|
||||||
|
+++ b/tools/idevicedate.c
|
||||||
|
@@ -38,9 +38,9 @@
|
||||||
|
#include <libimobiledevice/lockdown.h>
|
||||||
|
|
||||||
|
#ifdef _DATE_FMT
|
||||||
|
-#define DATE_FMT_LANGINFO() nl_langinfo (_DATE_FMT)
|
||||||
|
+#define DATE_FMT_LANGINFO nl_langinfo (_DATE_FMT)
|
||||||
|
#else
|
||||||
|
-#define DATE_FMT_LANGINFO() ""
|
||||||
|
+#define DATE_FMT_LANGINFO "%a %b %e %H:%M:%S %Z %Y"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
static void print_usage(int argc, char **argv)
|
||||||
|
@@ -75,7 +75,6 @@ int main(int argc, char *argv[])
|
||||||
|
uint64_t datetime = 0;
|
||||||
|
time_t rawtime;
|
||||||
|
struct tm * tmp;
|
||||||
|
- char const *format = NULL;
|
||||||
|
char buffer[80];
|
||||||
|
int result = 0;
|
||||||
|
|
||||||
|
@@ -131,14 +130,6 @@ int main(int argc, char *argv[])
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- /* determine a date format */
|
||||||
|
- if (!format) {
|
||||||
|
- format = DATE_FMT_LANGINFO ();
|
||||||
|
- if (!*format) {
|
||||||
|
- format = "%a %b %e %H:%M:%S %Z %Y";
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
ret = idevice_new(&device, udid);
|
||||||
|
if (ret != IDEVICE_E_SUCCESS) {
|
||||||
|
if (udid) {
|
||||||
|
@@ -195,7 +186,7 @@ int main(int argc, char *argv[])
|
||||||
|
tmp = localtime(&rawtime);
|
||||||
|
|
||||||
|
/* finally we format and print the current date */
|
||||||
|
- strftime(buffer, 80, format, tmp);
|
||||||
|
+ strftime(buffer, 80, DATE_FMT_LANGINFO, tmp);
|
||||||
|
puts(buffer);
|
||||||
|
} else {
|
||||||
|
datetime = setdate;
|
||||||
|
@@ -217,7 +208,7 @@ int main(int argc, char *argv[])
|
||||||
|
|
||||||
|
if(lockdownd_set_value(client, NULL, "TimeIntervalSince1970", node) == LOCKDOWN_E_SUCCESS) {
|
||||||
|
tmp = localtime(&setdate);
|
||||||
|
- strftime(buffer, 80, format, tmp);
|
||||||
|
+ strftime(buffer, 80, DATE_FMT_LANGINFO, tmp);
|
||||||
|
puts(buffer);
|
||||||
|
} else {
|
||||||
|
printf("ERROR: Failed to set date on device.\n");
|
Loading…
Reference in a new issue