bluez: update to 5.62
Refresh patches.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry picked from commit 3ee221d016
)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
30777cc241
commit
50f3d089fb
3 changed files with 13 additions and 12 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez
|
||||
PKG_VERSION:=5.60
|
||||
PKG_VERSION:=5.62
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/bluetooth/
|
||||
PKG_HASH:=710999580d01ee59ec585e5e7c07fd94eddedc001aa26fe7464c546f9d945304
|
||||
PKG_HASH:=38090a5b750e17fc08d3e52178ed8d3254c5f4bd2c48830d5c1955b88e3bc0c2
|
||||
|
||||
PKG_LICENSE:=GPL-2.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -3326,7 +3326,7 @@ unit_tests = $(am__append_52) unit/test-
|
||||
@CLIENT_TRUE@ client/gatt.h client/gatt.c
|
||||
@@ -3342,7 +3342,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@CLIENT_TRUE@ client/admin.c
|
||||
|
||||
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
-@CLIENT_TRUE@ $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
|
||||
|
@ -9,7 +9,7 @@
|
|||
|
||||
@ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
|
||||
@ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
|
||||
@@ -3559,7 +3559,7 @@ unit_tests = $(am__append_52) unit/test-
|
||||
@@ -3575,7 +3575,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ lib/libbluetooth-internal.la \
|
||||
|
@ -18,7 +18,7 @@
|
|||
|
||||
@MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
|
||||
@MESH_TRUE@@TOOLS_TRUE@ tools/mesh/model.h tools/mesh/config-model.h \
|
||||
@@ -3630,7 +3630,7 @@ unit_tests = $(am__append_52) unit/test-
|
||||
@@ -3646,7 +3646,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@ tools/obex-client-tool.c
|
||||
|
||||
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
@ -27,7 +27,7 @@
|
|||
|
||||
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
||||
@READLINE_TRUE@ tools/obex-server-tool.c
|
||||
@@ -3639,15 +3639,15 @@ unit_tests = $(am__append_52) unit/test-
|
||||
@@ -3655,15 +3655,15 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
||||
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
||||
@READLINE_TRUE@ src/libshared-glib.la \
|
||||
|
@ -46,7 +46,7 @@
|
|||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
||||
@@ -3656,7 +3656,7 @@ unit_tests = $(am__append_52) unit/test-
|
||||
@@ -3672,7 +3672,7 @@ unit_tests = $(am__append_54) unit/test-
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
||||
|
||||
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
||||
|
|
|
@ -34,11 +34,12 @@ This commit prevents the call to btd_adv_manager_refresh for non-LE devices.
|
|||
|
||||
--- a/src/adapter.c
|
||||
+++ b/src/adapter.c
|
||||
@@ -560,7 +560,8 @@ static void settings_changed(struct btd_
|
||||
g_dbus_emit_property_changed(dbus_conn, adapter->path,
|
||||
ADAPTER_INTERFACE, "Discoverable");
|
||||
store_adapter_info(adapter);
|
||||
@@ -606,7 +606,9 @@ static void settings_changed(struct btd_
|
||||
*/
|
||||
if (!adapter->discovery_discoverable)
|
||||
store_adapter_info(adapter);
|
||||
- btd_adv_manager_refresh(adapter->adv_manager);
|
||||
+
|
||||
+ if (adapter->supported_settings & MGMT_SETTING_LE)
|
||||
+ btd_adv_manager_refresh(adapter->adv_manager);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue