Merge pull request #1466 from jow-/usbip-musl-compat
usb: fix musl compatibility
This commit is contained in:
commit
50b3175b12
2 changed files with 12 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=usbip
|
PKG_NAME:=usbip
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=5
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
|
|
||||||
# Since kernel 2.6.39.1 userspace tools are inside the kernel tree
|
# Since kernel 2.6.39.1 userspace tools are inside the kernel tree
|
||||||
|
|
11
net/usbip/patches-2.0/100-musl-compat.patch
Normal file
11
net/usbip/patches-2.0/100-musl-compat.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/src/usbipd.c
|
||||||
|
+++ b/src/usbipd.c
|
||||||
|
@@ -453,7 +453,7 @@ static void set_signal(void)
|
||||||
|
sigaction(SIGTERM, &act, NULL);
|
||||||
|
sigaction(SIGINT, &act, NULL);
|
||||||
|
act.sa_handler = SIG_IGN;
|
||||||
|
- sigaction(SIGCLD, &act, NULL);
|
||||||
|
+ sigaction(SIGCHLD, &act, NULL);
|
||||||
|
}
|
||||||
|
|
||||||
|
static const char *pid_file;
|
Loading…
Reference in a new issue