libinput: update to 1.15.5
Converted to meson for speed. Removed all patches. The issues have all been fixed upstream. Minor cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
030cc5570c
commit
509ff35712
4 changed files with 17 additions and 72 deletions
|
@ -5,25 +5,22 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libinput
|
||||
PKG_VERSION:=1.7.3
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.15.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput/
|
||||
PKG_HASH:=096d612d2711f0caa2de544976ff3729e6233511ab373808644cc2dd5affcb1d
|
||||
PKG_HASH:=a90efc8f423c3094f2f9f372fb92381b2f3aad62e8b5882a8abe333aa8249c97
|
||||
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_DEPENDS:=meson/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
TARGET_CFLAGS+= -std=gnu99
|
||||
|
||||
CONFIGURE_ARGS += --disable-libwacom --disable-tests --disable-documentation
|
||||
include ../../devel/meson/meson.mk
|
||||
|
||||
define Package/libinput
|
||||
SECTION:=libs
|
||||
|
@ -41,11 +38,21 @@ define Package/libinput/description
|
|||
need to provide the common set of functionality that users expect.
|
||||
endef
|
||||
|
||||
MESON_ARGS += \
|
||||
-Depoll-dir=no \
|
||||
-Dlibwacom=false \
|
||||
-Ddebug-gui=false \
|
||||
-Dtests=false \
|
||||
-Dinstall-tests=false \
|
||||
-Ddocumentation=false \
|
||||
-Dcoverity=false \
|
||||
-Dzshcompletiondir=no
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{la,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- a/src/libinput-util.c
|
||||
+++ b/src/libinput-util.c
|
||||
@@ -31,7 +31,6 @@
|
||||
#include "config.h"
|
||||
|
||||
#include <ctype.h>
|
||||
-#include <locale.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdbool.h>
|
||||
#include <stdio.h>
|
||||
--- a/src/libinput-util.h
|
||||
+++ b/src/libinput-util.h
|
||||
@@ -30,7 +30,6 @@
|
||||
#include <assert.h>
|
||||
#include <errno.h>
|
||||
#include <limits.h>
|
||||
-#include <locale.h>
|
||||
#include <math.h>
|
||||
#include <stdarg.h>
|
||||
#include <stdbool.h>
|
||||
@@ -448,16 +447,8 @@ safe_atod(const char *str, double *val)
|
||||
{
|
||||
char *endptr;
|
||||
double v;
|
||||
- locale_t c_locale;
|
||||
|
||||
- /* Create a "C" locale to force strtod to use '.' as separator */
|
||||
- c_locale = newlocale(LC_NUMERIC_MASK, "C", (locale_t)0);
|
||||
- if (c_locale == (locale_t)0)
|
||||
- return false;
|
||||
-
|
||||
- errno = 0;
|
||||
- v = strtod_l(str, &endptr, c_locale);
|
||||
- freelocale(c_locale);
|
||||
+ v = strtod(str, &endptr);
|
||||
if (errno > 0)
|
||||
return false;
|
||||
if (str == endptr)
|
|
@ -1,14 +0,0 @@
|
|||
--- a/src/evdev-tablet.c
|
||||
+++ b/src/evdev-tablet.c
|
||||
@@ -1204,9 +1204,11 @@ static void
|
||||
tablet_mark_all_axes_changed(struct tablet_dispatch *tablet,
|
||||
struct libinput_tablet_tool *tool)
|
||||
{
|
||||
+#if 0
|
||||
static_assert(sizeof(tablet->changed_axes) ==
|
||||
sizeof(tool->axis_caps),
|
||||
"Mismatching array sizes");
|
||||
+#endif
|
||||
|
||||
memcpy(tablet->changed_axes,
|
||||
tool->axis_caps,
|
|
@ -1,10 +0,0 @@
|
|||
--- a/src/libinput.h
|
||||
+++ b/src/libinput.h
|
||||
@@ -29,6 +29,7 @@
|
||||
extern "C" {
|
||||
#endif
|
||||
|
||||
+#include <stdarg.h>
|
||||
#include <stdlib.h>
|
||||
#include <stdint.h>
|
||||
#include <libudev.h>
|
Loading…
Reference in a new issue