sumo: update to v0.26.0
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
This commit is contained in:
parent
d772bbc6a7
commit
500c519319
2 changed files with 16 additions and 14 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2015 OpenWrt.org
|
# Copyright (C) 2015-2016 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -8,12 +8,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=sumo
|
PKG_NAME:=sumo
|
||||||
PKG_VERSION:=0.25.0
|
PKG_VERSION:=0.26.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/sumo
|
PKG_SOURCE_URL:=@SF/sumo
|
||||||
PKG_MD5SUM:=6bfc4e1ff37fe4ba5d481ddc40323529
|
PKG_MD5SUM:=a3a9c5c5260bad87d1736cc7cda1cbca
|
||||||
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
|
||||||
|
|
||||||
PKG_LICENSE:=GPL-3.0
|
PKG_LICENSE:=GPL-3.0
|
||||||
|
@ -31,6 +31,8 @@ CONFIGURE_ARGS += \
|
||||||
--disable-dependency-tracking \
|
--disable-dependency-tracking \
|
||||||
--disable-silent-rules
|
--disable-silent-rules
|
||||||
|
|
||||||
|
TARGET_CXXFLAGS+=-fpermissive
|
||||||
|
|
||||||
define Package/sumo
|
define Package/sumo
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
|
|
|
@ -1,14 +1,14 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -13,11 +13,6 @@ AC_LANG([C++])
|
@@ -13,11 +13,6 @@ AC_LANG([C++])
|
||||||
|
case "$host" in
|
||||||
dnl the debug check has to be made before the program checks
|
x86-*-linux* | ia64-*-linux* | i586-*-linux* | i686-*-linux* | x86_64-*-linux*)
|
||||||
dnl because it modifies CXXFLAGS
|
dnl Make sure we are on architecture that supports SIMD
|
||||||
-if test x$CXX = xclang++; then
|
- if test x$CXX = xclang++; then
|
||||||
- CXXFLAGS="-msse2 $CXXFLAGS"
|
- CXXFLAGS="-msse2 $CXXFLAGS"
|
||||||
-else
|
- else
|
||||||
- CXXFLAGS="-msse2 -mfpmath=sse $CXXFLAGS"
|
- CXXFLAGS="-msse2 -mfpmath=sse $CXXFLAGS"
|
||||||
-fi
|
- fi
|
||||||
AC_ARG_ENABLE([debug], [AS_HELP_STRING([--enable-debug],[enable sumo debugging code [default=no].])])
|
;;
|
||||||
if test x$enable_debug = xyes; then
|
*-cygwin*)
|
||||||
AC_DEFINE(_DEBUG, 1, [Define to 1 in order to enable sumo debugging code.])
|
AC_DEFINE([HAVE_CYGWIN], [1], [Define if compiling under cygwin])
|
||||||
|
|
Loading…
Reference in a new issue