libshout: update to 2.4.5
Remove upstreamed patch. Switch to AUTORELEASE for simplicity. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
93d268b413
commit
500bed5935
2 changed files with 3 additions and 25 deletions
|
@ -6,12 +6,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libshout
|
||||
PKG_VERSION:=2.4.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=2.4.5
|
||||
PKG_RELEASE:=$(AUTORELEASE)
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://downloads.us.xiph.org/releases/libshout/
|
||||
PKG_HASH:=8ce90c5d05e7ad1da4c12f185837e8a867c22df2d557b0125afaba4b1438e6c3
|
||||
PKG_HASH:=d9e568668a673994ebe3f1eb5f2bee06e3236a5db92b8d0c487e1c0f886a6890
|
||||
|
||||
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
||||
PKG_LICENSE:=LGPL-2.1-or-later
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
--- a/examples/nonblocking.c
|
||||
+++ b/examples/nonblocking.c
|
||||
@@ -6,6 +6,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <time.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include <shout/shout.h>
|
||||
@@ -70,8 +71,10 @@ int main()
|
||||
if (ret == SHOUTERR_BUSY)
|
||||
printf("Connection pending...\n");
|
||||
|
||||
+ const struct timespec req = {0, 10 * 1000 * 1000};
|
||||
+ struct timespec rem;
|
||||
while (ret == SHOUTERR_BUSY) {
|
||||
- usleep(10000);
|
||||
+ nanosleep(&req, &rem);
|
||||
ret = shout_get_connected(shout);
|
||||
}
|
||||
|
Loading…
Reference in a new issue