node: update to v14.15.3
Maintainer: me @ianchi Compile tested: head r15324-920b692, aarch64, x86_64 Run tested: (qemu 5.2.0) aarch64, x86_64 Description: Update to v14.15.3 Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
This commit is contained in:
parent
740740d219
commit
4fea76cc01
6 changed files with 16 additions and 19 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=node
|
||||
PKG_VERSION:=v14.15.1
|
||||
PKG_VERSION:=v14.15.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
|
||||
PKG_HASH:=0161436846f7578938ad87af197e0cf112452232723227f88d5a0efc34dec1bc
|
||||
PKG_HASH:=32cfb19be9bd15cfdfaf842b29c80cc1c1c4b841a3b8ce05de74e1aca1cbf4fe
|
||||
|
||||
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
|
||||
PKG_LICENSE:=MIT
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/lib/internal/modules/cjs/loader.js
|
||||
+++ b/lib/internal/modules/cjs/loader.js
|
||||
@@ -1179,7 +1179,8 @@
|
||||
@@ -1179,7 +1179,8 @@ Module._initPaths = function() {
|
||||
path.resolve(process.execPath, '..') :
|
||||
path.resolve(process.execPath, '..', '..');
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -urN a/deps/v8/src/base/platform/condition-variable.cc b/deps/v8/src/base/platform/condition-variable.cc
|
||||
--- a/deps/v8/src/base/platform/condition-variable.cc 2020-09-30 01:58:13.000000000 +0900
|
||||
+++ b/deps/v8/src/base/platform/condition-variable.cc 2020-10-06 09:04:33.341499270 +0900
|
||||
@@ -16,7 +16,7 @@
|
||||
--- a/deps/v8/src/base/platform/condition-variable.cc
|
||||
+++ b/deps/v8/src/base/platform/condition-variable.cc
|
||||
@@ -16,7 +16,7 @@ namespace base {
|
||||
|
||||
ConditionVariable::ConditionVariable() {
|
||||
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
|
||||
|
@ -10,7 +9,7 @@ diff -urN a/deps/v8/src/base/platform/condition-variable.cc b/deps/v8/src/base/p
|
|||
// On Free/Net/OpenBSD and Linux with glibc we can change the time
|
||||
// source for pthread_cond_timedwait() to use the monotonic clock.
|
||||
pthread_condattr_t attr;
|
||||
@@ -92,7 +92,7 @@
|
||||
@@ -92,7 +92,7 @@ bool ConditionVariable::WaitFor(Mutex* m
|
||||
&native_handle_, &mutex->native_handle(), &ts);
|
||||
#else
|
||||
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
|
||||
|
@ -19,10 +18,9 @@ diff -urN a/deps/v8/src/base/platform/condition-variable.cc b/deps/v8/src/base/p
|
|||
// On Free/Net/OpenBSD and Linux with glibc we can change the time
|
||||
// source for pthread_cond_timedwait() to use the monotonic clock.
|
||||
result = clock_gettime(CLOCK_MONOTONIC, &ts);
|
||||
diff -urN a/deps/v8/src/base/platform/platform-posix.cc b/deps/v8/src/base/platform/platform-posix.cc
|
||||
--- a/deps/v8/src/base/platform/platform-posix.cc 2020-09-30 01:58:13.000000000 +0900
|
||||
+++ b/deps/v8/src/base/platform/platform-posix.cc 2020-10-06 09:04:33.341499270 +0900
|
||||
@@ -823,7 +823,7 @@
|
||||
--- a/deps/v8/src/base/platform/platform-posix.cc
|
||||
+++ b/deps/v8/src/base/platform/platform-posix.cc
|
||||
@@ -823,7 +823,7 @@ bool Thread::Start() {
|
||||
#if V8_OS_MACOSX
|
||||
// Default on Mac OS X is 512kB -- bump up to 1MB
|
||||
stack_size = 1 * 1024 * 1024;
|
||||
|
@ -31,9 +29,8 @@ diff -urN a/deps/v8/src/base/platform/platform-posix.cc b/deps/v8/src/base/platf
|
|||
// Default on AIX is 96kB -- bump up to 2MB
|
||||
stack_size = 2 * 1024 * 1024;
|
||||
#endif
|
||||
diff -urN a/deps/v8/src/codegen/external-reference-table.cc b/deps/v8/src/codegen/external-reference-table.cc
|
||||
--- a/deps/v8/src/codegen/external-reference-table.cc 2020-09-30 01:58:13.000000000 +0900
|
||||
+++ b/deps/v8/src/codegen/external-reference-table.cc 2020-10-06 09:04:33.345499241 +0900
|
||||
--- a/deps/v8/src/codegen/external-reference-table.cc
|
||||
+++ b/deps/v8/src/codegen/external-reference-table.cc
|
||||
@@ -9,7 +9,7 @@
|
||||
#include "src/ic/stub-cache.h"
|
||||
#include "src/logging/counters.h"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/tools/gyp/pylib/gyp/generator/make.py
|
||||
+++ b/tools/gyp/pylib/gyp/generator/make.py
|
||||
@@ -180,7 +180,7 @@
|
||||
@@ -180,7 +180,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
|
||||
|
||||
LINK_COMMANDS_MAC = """\
|
||||
quiet_cmd_alink = LIBTOOL-STATIC $@
|
||||
|
|
|
@ -32,8 +32,8 @@
|
|||
'dependencies': [ 'icutools' ],
|
||||
'sources': [
|
||||
'<@(icu_src_genccode)',
|
||||
--- a/tools/v8_gypfiles/v8.gyp 2019-06-27 19:12:20.000000000 +0900
|
||||
+++ b/tools/v8_gypfiles/v8.gyp 2019-07-01 14:40:48.292020880 +0900
|
||||
--- a/tools/v8_gypfiles/v8.gyp
|
||||
+++ b/tools/v8_gypfiles/v8.gyp
|
||||
@@ -1310,6 +1310,7 @@
|
||||
{
|
||||
'target_name': 'bytecode_builtins_list_generator',
|
||||
|
|
|
@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
|
|||
//
|
||||
// Permission is hereby granted, free of charge, to any person obtaining a
|
||||
// copy of this software and associated documentation files (the
|
||||
@@ -1026,13 +1027,6 @@
|
||||
@@ -1026,13 +1027,6 @@ function lookupAndConnect(self, options)
|
||||
hints: options.hints || 0
|
||||
};
|
||||
|
||||
|
|
Loading…
Reference in a new issue