libpciaccess: Update to 0.16
Add PKG_LICENSE_FILES. Small Makefile rearrangements for consistency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
1b4f838815
commit
4f8d7b2d8e
2 changed files with 9 additions and 36 deletions
|
@ -6,17 +6,18 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libpciaccess
|
PKG_NAME:=libpciaccess
|
||||||
PKG_VERSION:=0.14
|
PKG_VERSION:=0.16
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE_URL:=https://www.x.org/releases/individual/lib/
|
PKG_SOURCE_URL:=https://www.x.org/releases/individual/lib/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_HASH:=3df543e12afd41fea8eac817e48cbfde5aed8817b81670a4e9e493bb2f5bf2a4
|
PKG_HASH:=214c9d0d884fdd7375ec8da8dcb91a8d3169f263294c9a90c575bf1938b9f489
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
PKG_MAINTAINER:= Lucian Cristian <lucian.cristian@gmail.com>
|
PKG_MAINTAINER:= Lucian Cristian <lucian.cristian@gmail.com>
|
||||||
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -27,10 +28,10 @@ define Package/libpciaccess
|
||||||
URL:=https://xorg.freedesktop.org/
|
URL:=https://xorg.freedesktop.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--prefix=/usr
|
--prefix=/usr
|
||||||
|
|
||||||
|
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) \
|
$(INSTALL_DIR) \
|
||||||
|
|
|
@ -1,28 +0,0 @@
|
||||||
From b6df5202306bd71158b482f25ca2e6919645d4dd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Khem Raj <raj.khem@gmail.com>
|
|
||||||
Date: Thu, 4 Jun 2015 20:55:06 -0700
|
|
||||||
Subject: [PATCH 4/4] Don't include sys/io.h on arm
|
|
||||||
|
|
||||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
||||||
---
|
|
||||||
Upstream-Status: Pending
|
|
||||||
|
|
||||||
src/linux_sysfs.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/linux_sysfs.c b/src/linux_sysfs.c
|
|
||||||
index 3f95e53..1e3aad3 100644
|
|
||||||
--- a/src/linux_sysfs.c
|
|
||||||
+++ b/src/linux_sysfs.c
|
|
||||||
@@ -50,7 +50,7 @@
|
|
||||||
#include <dirent.h>
|
|
||||||
#include <errno.h>
|
|
||||||
|
|
||||||
-#if defined(__i386__) || defined(__x86_64__) || defined(__arm__)
|
|
||||||
+#if defined(__i386__) || defined(__x86_64__)
|
|
||||||
#include <sys/io.h>
|
|
||||||
#else
|
|
||||||
#define inb(x) -1
|
|
||||||
--
|
|
||||||
2.1.4
|
|
||||||
|
|
Loading…
Reference in a new issue