crowdsec: update to 1.2.1
crowdsec-firewall-boucer: update to 0.0.16
Signed-off-by: Kerma Gérald <gandalf@gk2.net>
(cherry picked from commit 2861370567
)
Signed-off-by: Kerma Gérald <gandalf@gk2.net>
This commit is contained in:
parent
f71a9c91cb
commit
4f78eb825f
3 changed files with 6 additions and 35 deletions
|
@ -6,14 +6,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=crowdsec-firewall-bouncer
|
PKG_NAME:=crowdsec-firewall-bouncer
|
||||||
PKG_VERSION:=0.0.15
|
PKG_VERSION:=0.0.16
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/crowdsecurity/cs-firewall-bouncer
|
PKG_SOURCE_URL:=https://github.com/crowdsecurity/cs-firewall-bouncer
|
||||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||||
PKG_SOURCE_DATE:=2021903
|
PKG_SOURCE_DATE:=20211117
|
||||||
PKG_MIRROR_HASH:=2ef7e4f935056d648a6b45bb09ebb5846262ac9d745229b1442051abdd214c86
|
PKG_MIRROR_HASH:=769a01bcee0ac27627fc00a59259ca09f89f382fc228c7bb24dc5d7df8ae9a12
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -6,14 +6,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=crowdsec
|
PKG_NAME:=crowdsec
|
||||||
PKG_VERSION:=1.2.0
|
PKG_VERSION:=1.2.1
|
||||||
PKG_RELEASE:=$(AUTORELEASE)
|
PKG_RELEASE:=$(AUTORELEASE)
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/crowdsecurity/crowdsec
|
PKG_SOURCE_URL:=https://github.com/crowdsecurity/crowdsec
|
||||||
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
||||||
PKG_SOURCE_DATE:=20210914
|
PKG_SOURCE_DATE:=20211117
|
||||||
PKG_MIRROR_HASH:=911af2c49c28596256c31ebb26b48c5ba9e6a0abdd46830e75e2cf4c0eff4256
|
PKG_MIRROR_HASH:=dfe50e5fb4d32fb6c21275b3f13a837ad64a9054e78076b44325376dc003fc64
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=LICENSE
|
PKG_LICENSE_FILES:=LICENSE
|
||||||
|
|
|
@ -1,29 +0,0 @@
|
||||||
Author: Kerma Gérald <gandalf@gk2.net>
|
|
||||||
Date: Mon Sep 20 10:34:20 2021 +0200
|
|
||||||
|
|
||||||
Use math.MaxInt32 instead of math.MaxUint32
|
|
||||||
|
|
||||||
To fix 32 bits compilation in v1.2.0
|
|
||||||
https://github.com/crowdsecurity/crowdsec/issues/979
|
|
||||||
|
|
||||||
Signed-off-by: Kerma Gérald <gandalf@gk2.net>
|
|
||||||
|
|
||||||
--- a/pkg/csplugin/broker.go
|
|
||||||
+++ b/pkg/csplugin/broker.go
|
|
||||||
@@ -400,14 +400,14 @@ func getProccessAtr(username string, gro
|
|
||||||
if err != nil {
|
|
||||||
return nil, err
|
|
||||||
}
|
|
||||||
- if uid < 0 && uid > math.MaxUint32 {
|
|
||||||
+ if uid < 0 && uid > math.MaxInt32 {
|
|
||||||
return nil, fmt.Errorf("out of bound uid")
|
|
||||||
}
|
|
||||||
gid, err := strconv.Atoi(g.Gid)
|
|
||||||
if err != nil {
|
|
||||||
return nil, err
|
|
||||||
}
|
|
||||||
- if gid < 0 && gid > math.MaxUint32 {
|
|
||||||
+ if gid < 0 && gid > math.MaxInt32 {
|
|
||||||
return nil, fmt.Errorf("out of bound gid")
|
|
||||||
}
|
|
||||||
return &syscall.SysProcAttr{
|
|
Loading…
Reference in a new issue