twisted: update to 16.4.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
e5307a8c4c
commit
4f234e7641
2 changed files with 17 additions and 13 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2006-2016 OpenWrt.org
|
||||
# Copyright (C) 2006-2011, 2015-2016 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,13 +8,13 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=twisted
|
||||
PKG_VERSION:=16.3.0
|
||||
PKG_VERSION:=16.4.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/c0/7c/c1e5b61e30b7ffc96576d2a922615c8068e6996a622be813fc626cef07aa \
|
||||
http://twistedmatrix.com/Releases/Twisted/16.3
|
||||
PKG_MD5SUM:=e044af844623e9fbcbe29f578db6053a
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/6b/23/8dbe86fc83215015e221fbd861a545c6ec5c9e9cd7514af114d1f64084ab \
|
||||
http://twistedmatrix.com/Releases/Twisted/16.4
|
||||
PKG_MD5SUM:=c6d09bdd681f538369659111f079c29d
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Twisted-$(PKG_VERSION)
|
||||
PKG_BUILD_DEPENDS:=python python-setuptools USE_MUSL:librpc
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
diff --git a/setup.py b/setup.py
|
||||
index d10f17d..d347d64 100755
|
||||
index e21ef70..a4d9ee8 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -40,11 +40,12 @@ def main(args):
|
||||
@@ -55,13 +55,14 @@ def main(args):
|
||||
setup_args = STATIC_PACKAGE_METADATA.copy()
|
||||
|
||||
setup_args.update(dict(
|
||||
|
@ -10,28 +10,32 @@ index d10f17d..d347d64 100755
|
|||
+ packages=setuptools.find_packages(exclude=["*.test", "*.test.*"]),
|
||||
install_requires=requirements,
|
||||
conditionalExtensions=getExtensions(),
|
||||
scripts=getScripts(),
|
||||
entry_points={
|
||||
'console_scripts': getConsoleScripts()
|
||||
},
|
||||
include_package_data=True,
|
||||
+ exclude_package_data={'':['test/*']},
|
||||
zip_safe=False,
|
||||
extras_require=_EXTRAS_REQUIRE,
|
||||
))
|
||||
diff --git a/twisted/python/dist.py b/twisted/python/dist.py
|
||||
index aac2756..5633f09 100644
|
||||
index dfff9dc..a05b716 100644
|
||||
--- a/twisted/python/dist.py
|
||||
+++ b/twisted/python/dist.py
|
||||
@@ -182,10 +182,10 @@ def getExtensions():
|
||||
@@ -191,11 +191,11 @@ def getExtensions():
|
||||
Get the C extensions used for Twisted.
|
||||
"""
|
||||
extensions = [
|
||||
- ConditionalExtension(
|
||||
- "twisted.test.raiser",
|
||||
- ["twisted/test/raiser.c"],
|
||||
- condition=lambda _: _isCPython),
|
||||
- condition=lambda _: _isCPython
|
||||
- ),
|
||||
+ #ConditionalExtension(
|
||||
+ # "twisted.test.raiser",
|
||||
+ # ["twisted/test/raiser.c"],
|
||||
+ # condition=lambda _: _isCPython),
|
||||
|
||||
+ # condition=lambda _: _isCPython
|
||||
+ #),
|
||||
ConditionalExtension(
|
||||
"twisted.internet.iocpreactor.iocpsupport",
|
||||
["twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
|
||||
|
|
Loading…
Reference in a new issue