irqbalance: fix socket directory and create it
Irqbalance defines /run/irqbalance dir for its socket communication between irqbalance and its UI. /run does not exist in OpenWrt (although it is defined by the Linux FHS), so the socket creation fails. Although we do not compile UI and thus the issue is not critical to us, fix the directory location. Additionally, the creation is originally handled by a systemd init script that we do not use. * patch source to define dir as /var/run/irqbalance * create the dir in the procd init script. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
c8187f7f16
commit
4f0c847828
3 changed files with 25 additions and 1 deletions
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=irqbalance
|
||||
PKG_VERSION:=1.6.0
|
||||
PKG_RELEASE:=9
|
||||
PKG_RELEASE:=10
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_PROTO:=git
|
||||
|
|
|
@ -16,6 +16,8 @@ start_service() {
|
|||
config_get_bool enabled irqbalance enabled 0
|
||||
[ "$enabled" -gt 0 ] || return 0
|
||||
|
||||
mkdir -p /var/run/irqbalance
|
||||
|
||||
# 10 is the default
|
||||
config_get interval irqbalance interval 10
|
||||
|
||||
|
|
|
@ -0,0 +1,22 @@
|
|||
--- a/irqbalance.h
|
||||
+++ b/irqbalance.h
|
||||
@@ -158,7 +158,7 @@ extern unsigned int log_mask;
|
||||
#endif /* HAVE_LIBSYSTEMD */
|
||||
|
||||
#define SOCKET_PATH "irqbalance"
|
||||
-#define SOCKET_TMPFS "/run/irqbalance/"
|
||||
+#define SOCKET_TMPFS "/var/run/irqbalance/"
|
||||
|
||||
#endif /* __INCLUDE_GUARD_IRQBALANCE_H_ */
|
||||
|
||||
--- a/ui/irqbalance-ui.h
|
||||
+++ b/ui/irqbalance-ui.h
|
||||
@@ -8,7 +8,7 @@
|
||||
#include <glib-unix.h>
|
||||
|
||||
#define SOCKET_PATH "irqbalance"
|
||||
-#define SOCKET_TMPFS "/run/irqbalance"
|
||||
+#define SOCKET_TMPFS "/var/run/irqbalance"
|
||||
|
||||
#define STATS "stats"
|
||||
#define SET_SLEEP "settings sleep "
|
Loading…
Reference in a new issue