haproxy: fix from upstream
[PATCH 4/4] BUG: config: error in http-response replace-header number Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
This commit is contained in:
parent
2822192234
commit
4eec42a248
2 changed files with 35 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=haproxy
|
||||
PKG_VERSION:=1.5.3
|
||||
PKG_RELEASE:=03
|
||||
PKG_RELEASE:=04
|
||||
PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
|
||||
PKG_MD5SUM:=e999a547d57445d5a5ab7eb6a06df9a1
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
From a772b945d757c25037ac58de64ccc27ceeb4b4a7 Mon Sep 17 00:00:00 2001
|
||||
From: Baptiste Assmann <bedis9@gmail.com>
|
||||
Date: Fri, 8 Aug 2014 17:29:06 +0200
|
||||
Subject: [PATCH 4/4] BUG: config: error in http-response replace-header number
|
||||
of arguments
|
||||
|
||||
A couple of typo fixed in 'http-response replace-header':
|
||||
- an error when counting the number of arguments
|
||||
- a typo in the alert message
|
||||
|
||||
This should be backported to 1.5.
|
||||
(cherry picked from commit 12cb00b216d67468b7c4bd84abedcb4ecd1a32bc)
|
||||
---
|
||||
src/proto_http.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/proto_http.c b/src/proto_http.c
|
||||
index b7ed85d..2b75b32 100644
|
||||
--- a/src/proto_http.c
|
||||
+++ b/src/proto_http.c
|
||||
@@ -9281,8 +9281,8 @@ struct http_res_rule *parse_http_res_cond(const char **args, const char *file, i
|
||||
cur_arg = 1;
|
||||
|
||||
if (!*args[cur_arg] || !*args[cur_arg+1] || !*args[cur_arg+2] ||
|
||||
- (*args[cur_arg+3] && strcmp(args[cur_arg+2], "if") != 0 && strcmp(args[cur_arg+2], "unless") != 0)) {
|
||||
- Alert("parsing [%s:%d]: 'http-request %s' expects exactly 3 arguments.\n",
|
||||
+ (*args[cur_arg+3] && strcmp(args[cur_arg+3], "if") != 0 && strcmp(args[cur_arg+3], "unless") != 0)) {
|
||||
+ Alert("parsing [%s:%d]: 'http-response %s' expects exactly 3 arguments.\n",
|
||||
file, linenum, args[0]);
|
||||
goto out_err;
|
||||
}
|
||||
--
|
||||
1.8.5.5
|
||||
|
Loading…
Reference in a new issue