Merge pull request #3797 from diizzyy/patch-21
net/transmission: Refresh patches and minor tweaks
This commit is contained in:
commit
4e9adcbac4
5 changed files with 35 additions and 10 deletions
|
@ -15,7 +15,8 @@ PKG_SOURCE_PROTO:=git
|
||||||
PKG_SOURCE_URL:=https://github.com/transmission/transmission.git
|
PKG_SOURCE_URL:=https://github.com/transmission/transmission.git
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
PKG_SOURCE_VERSION:=35fea28d1a37875ef7480ac061754df617805b19
|
PKG_SOURCE_VERSION:=35fea28d1a37875ef7480ac061754df617805b19
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
|
||||||
|
PKG_MIRROR_MD5SUM:=aeeb8dfd918bd2cf4fb6fbdf58bd822e9b509df1ba5ec408888edd161123ef8e
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -378,7 +378,7 @@ dnl See if ANY version of miniupnpc is i
|
@@ -386,7 +386,7 @@ dnl See if ANY version of miniupnpc is i
|
||||||
AC_LINK_IFELSE(
|
AC_LINK_IFELSE(
|
||||||
[AC_LANG_PROGRAM([#include <miniupnpc/miniupnpc.h>],
|
[AC_LANG_PROGRAM([#include <miniupnpc/miniupnpc.h>],
|
||||||
[struct UPNPDev dev;])],
|
[struct UPNPDev dev;])],
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
--- a/libtransmission/bitfield.c
|
--- a/libtransmission/bitfield.c
|
||||||
+++ b/libtransmission/bitfield.c
|
+++ b/libtransmission/bitfield.c
|
||||||
@@ -7,6 +7,8 @@
|
@@ -6,6 +6,8 @@
|
||||||
* $Id: bitfield.c 14646 2015-12-31 05:22:42Z mikedld $
|
*
|
||||||
*/
|
*/
|
||||||
|
|
||||||
+#define __NEED_ssize_t
|
+#define __NEED_ssize_t
|
||||||
|
@ -9,7 +9,7 @@
|
||||||
#include <assert.h>
|
#include <assert.h>
|
||||||
#include <string.h> /* memset */
|
#include <string.h> /* memset */
|
||||||
|
|
||||||
@@ -14,6 +16,7 @@
|
@@ -13,6 +15,7 @@
|
||||||
#include "bitfield.h"
|
#include "bitfield.h"
|
||||||
#include "utils.h" /* tr_new0 () */
|
#include "utils.h" /* tr_new0 () */
|
||||||
|
|
||||||
|
@ -19,7 +19,7 @@
|
||||||
/****
|
/****
|
||||||
--- a/libtransmission/fdlimit.h
|
--- a/libtransmission/fdlimit.h
|
||||||
+++ b/libtransmission/fdlimit.h
|
+++ b/libtransmission/fdlimit.h
|
||||||
@@ -11,6 +11,8 @@
|
@@ -10,6 +10,8 @@
|
||||||
#error only libtransmission should #include this header.
|
#error only libtransmission should #include this header.
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
|
|
@ -1,10 +1,9 @@
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -153,25 +153,9 @@
|
@@ -154,24 +154,8 @@ AS_IF([test "x$want_crypto" = "xauto" -o
|
||||||
])
|
|
||||||
AS_IF([test "x$want_crypto" = "xauto" -o "x$want_crypto" = "xpolarssl"], [
|
AS_IF([test "x$want_crypto" = "xauto" -o "x$want_crypto" = "xpolarssl"], [
|
||||||
PKG_CHECK_MODULES(MBEDTLS, [mbedtls >= $POLARSSL_MINIMUM],
|
PKG_CHECK_MODULES(MBEDTLS, [mbedtls >= $POLARSSL_MINIMUM],
|
||||||
- [want_crypto="polarssl"; CRYPTO_PKG="polarssl"; CRYPTO_CFLAGS="$MBEDTLS_CFLAGS"; CRYPTO_LIBS="$MBEDTLS_LIBS"; POLARSSL_IS_MBEDTLS=yes],
|
[want_crypto="polarssl"; CRYPTO_PKG="polarssl"; CRYPTO_CFLAGS="$MBEDTLS_CFLAGS"; CRYPTO_LIBS="$MBEDTLS_LIBS"; POLARSSL_IS_MBEDTLS=yes],
|
||||||
- [AC_CHECK_HEADER([polarssl/version.h],
|
- [AC_CHECK_HEADER([polarssl/version.h],
|
||||||
- [AC_EGREP_CPP([version_ok], [#include <polarssl/version.h>
|
- [AC_EGREP_CPP([version_ok], [#include <polarssl/version.h>
|
||||||
- #if defined (POLARSSL_VERSION_NUMBER) && POLARSSL_VERSION_NUMBER >= $POLARSSL_MINIMUM
|
- #if defined (POLARSSL_VERSION_NUMBER) && POLARSSL_VERSION_NUMBER >= $POLARSSL_MINIMUM
|
||||||
|
@ -23,7 +22,6 @@
|
||||||
- [AS_IF([test "x$want_crypto" = "xpolarssl"],
|
- [AS_IF([test "x$want_crypto" = "xpolarssl"],
|
||||||
- [AC_MSG_ERROR([PolarSSL support requested, but headers not found.])]
|
- [AC_MSG_ERROR([PolarSSL support requested, but headers not found.])]
|
||||||
- )]
|
- )]
|
||||||
+ [want_crypto="polarssl"; CRYPTO_PKG="polarssl"; CRYPTO_CFLAGS="$MBEDTLS_CFLAGS"; CRYPTO_LIBS="$MBEDTLS_LIBS"; POLARSSL_IS_MBEDTLS=yes],
|
|
||||||
+ [AS_IF([test "x$want_crypto" = "xpolarssl"],
|
+ [AS_IF([test "x$want_crypto" = "xpolarssl"],
|
||||||
+ [AC_MSG_ERROR([PolarSSL support requested, but library not found.])]
|
+ [AC_MSG_ERROR([PolarSSL support requested, but library not found.])]
|
||||||
)]
|
)]
|
||||||
|
|
26
net/transmission/patches/050-mask-as-release.patch
Normal file
26
net/transmission/patches/050-mask-as-release.patch
Normal file
|
@ -0,0 +1,26 @@
|
||||||
|
--- a/CMakeLists.txt
|
||||||
|
+++ b/CMakeLists.txt
|
||||||
|
@@ -42,8 +42,8 @@ set(TR_NAME ${PROJECT_NAME})
|
||||||
|
# "Z" for unsupported trunk builds,
|
||||||
|
# "0" for stable, supported releases
|
||||||
|
# these should be the only two lines you need to change
|
||||||
|
-set(TR_USER_AGENT_PREFIX "2.92+")
|
||||||
|
-set(TR_PEER_ID_PREFIX "-TR292Z-")
|
||||||
|
+set(TR_USER_AGENT_PREFIX "2.92")
|
||||||
|
+set(TR_PEER_ID_PREFIX "-TR2920-")
|
||||||
|
|
||||||
|
string(REGEX MATCH "^([0-9]+)\\.([0-9]+).*" TR_VERSION "${TR_USER_AGENT_PREFIX}")
|
||||||
|
set(TR_VERSION_MAJOR "${CMAKE_MATCH_1}")
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -3,8 +3,8 @@ dnl STATUS: "X" for prerelease beta buil
|
||||||
|
dnl "Z" for unsupported trunk builds,
|
||||||
|
dnl "0" for stable, supported releases
|
||||||
|
dnl these should be the only two lines you need to change
|
||||||
|
-m4_define([user_agent_prefix],[2.92+])
|
||||||
|
-m4_define([peer_id_prefix],[-TR292Z-])
|
||||||
|
+m4_define([user_agent_prefix],[2.92])
|
||||||
|
+m4_define([peer_id_prefix],[-TR2920-])
|
||||||
|
|
||||||
|
AC_INIT([transmission],[user_agent_prefix],[https://trac.transmissionbt.com/newticket])
|
||||||
|
AC_SUBST(USERAGENT_PREFIX,[user_agent_prefix])
|
Loading…
Reference in a new issue