tcsh: fix out of memory crash
Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
This commit is contained in:
parent
aacfbb244a
commit
4e82a56ccd
2 changed files with 17 additions and 2 deletions
|
@ -1,5 +1,5 @@
|
|||
#
|
||||
# Copyright (C) 2011-2016 OpenWrt.org
|
||||
# Copyright (C) 2011-2017 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
|
@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=tcsh
|
||||
PKG_VERSION:=6.20.00
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
|
|
15
utils/tcsh/patches/001-sysmalloc.patch
Normal file
15
utils/tcsh/patches/001-sysmalloc.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- a/config_f.h
|
||||
+++ b/config_f.h
|
||||
@@ -139,11 +139,8 @@
|
||||
* This can be much slower and no memory statistics will be
|
||||
* provided.
|
||||
*/
|
||||
-#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__GLIBC__) || defined(__OpenBSD__) || defined(__APPLE__) || defined (__ANDROID__)
|
||||
+
|
||||
# define SYSMALLOC
|
||||
-#else
|
||||
-# undef SYSMALLOC
|
||||
-#endif
|
||||
|
||||
/*
|
||||
* USE_ACCESS Use access(2) rather than stat(2) when POSIX is defined.
|
Loading…
Reference in a new issue