python: use built-in libffi lib for host build
Python comes with it's own builtin libffi lib, which seems easier to use for the host build, than trying to use the one from the package feeds. Also, dropping `005-fix-libffi-x86-64-configure.patch` Not needed anymore. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
ee88853e04
commit
4e2f4a76e3
2 changed files with 2 additions and 33 deletions
|
@ -36,7 +36,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=python/host
|
PKG_BUILD_DEPENDS:=python/host
|
||||||
HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host
|
HOST_BUILD_DEPENDS:=bzip2/host expat/host
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -239,7 +239,7 @@ HOST_CONFIGURE_ARGS+= \
|
||||||
--prefix=$(HOST_PYTHON_DIR) \
|
--prefix=$(HOST_PYTHON_DIR) \
|
||||||
--exec-prefix=$(HOST_PYTHON_DIR) \
|
--exec-prefix=$(HOST_PYTHON_DIR) \
|
||||||
--with-system-expat=$(STAGING_DIR_HOSTPKG) \
|
--with-system-expat=$(STAGING_DIR_HOSTPKG) \
|
||||||
--with-system-ffi \
|
--with-system-ffi=no \
|
||||||
CONFIG_SITE=
|
CONFIG_SITE=
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
diff --git a/Modules/_ctypes/libffi/configure b/Modules/_ctypes/libffi/configure
|
|
||||||
index 75f62a7..4d6c9f2 100755
|
|
||||||
--- a/Modules/_ctypes/libffi/configure
|
|
||||||
+++ b/Modules/_ctypes/libffi/configure
|
|
||||||
@@ -17257,20 +17257,12 @@ case "$host" in
|
|
||||||
fi
|
|
||||||
;;
|
|
||||||
|
|
||||||
- i?86-*-* | x86_64-*-*)
|
|
||||||
- TARGETDIR=x86
|
|
||||||
- if test $ac_cv_sizeof_size_t = 4; then
|
|
||||||
- case "$host" in
|
|
||||||
- *-gnux32)
|
|
||||||
- TARGET=X86_64
|
|
||||||
- ;;
|
|
||||||
- *)
|
|
||||||
- TARGET=X86
|
|
||||||
- ;;
|
|
||||||
- esac
|
|
||||||
- else
|
|
||||||
- TARGET=X86_64;
|
|
||||||
- fi
|
|
||||||
+ i?86-*-*)
|
|
||||||
+ TARGET=X86; TARGETDIR=x86
|
|
||||||
+ ;;
|
|
||||||
+
|
|
||||||
+ x86_64-*-*)
|
|
||||||
+ TARGET=X86_64; TARGETDIR=x86
|
|
||||||
;;
|
|
||||||
|
|
||||||
ia64*-*-*)
|
|
Loading…
Reference in a new issue