miniupnpd: update to 2.2.0
Replace daemon patch with upstream solution. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
23c93e7fcc
commit
4d824243e6
2 changed files with 6 additions and 29 deletions
|
@ -8,13 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=miniupnpd
|
||||
PKG_VERSION:=2.1.20200510
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=2.2.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=https://miniupnp.tuxfamily.org/files
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=821e708f369cc1fb851506441fbc3a1f4a1b5a8bf8e84a9e71758a32f5127e8b
|
||||
PKG_HASH:=f105210a13ed0ebfc649f661ecc59e0a072cc547b04977851f22b5521b4cadff
|
||||
|
||||
PKG_MAINTAINER:=
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=LICENSE
|
||||
PKG_CPE_ID:=cpe:/a:miniupnp_project:miniupnpd
|
||||
|
@ -48,7 +49,8 @@ CONFIGURE_ARGS = \
|
|||
--igd2 \
|
||||
--leasefile \
|
||||
--portinuse \
|
||||
--firewall=iptables
|
||||
--firewall=iptables \
|
||||
--disable-fork
|
||||
|
||||
TARGET_CFLAGS += $(FPIC) -flto
|
||||
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- a/miniupnpd.c
|
||||
+++ b/miniupnpd.c
|
||||
@@ -1769,21 +1769,7 @@ init(int argc, char * * argv, struct run
|
||||
}
|
||||
}
|
||||
|
||||
- if(debug_flag)
|
||||
- {
|
||||
- pid = getpid();
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
-#ifdef USE_DAEMON
|
||||
- if(daemon(0, 0)<0) {
|
||||
- perror("daemon()");
|
||||
- }
|
||||
- pid = getpid();
|
||||
-#else
|
||||
- pid = daemonize();
|
||||
-#endif
|
||||
- }
|
||||
+ pid = getpid();
|
||||
|
||||
openlog_option = LOG_PID|LOG_CONS;
|
||||
if(debug_flag)
|
Loading…
Reference in a new issue