libmpc: Add package
From the documentation: GNU MPC is a portable library written in C for arbitrary precision arithmetic on complex numbers providing correct rounding. It implements a multiprecision equivalent of the C99 standard. It builds upon the GNU MP and the GNU MPFR libraries. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
925bd16945
commit
4d64d5f80a
2 changed files with 79 additions and 0 deletions
57
libs/libmpc/Makefile
Normal file
57
libs/libmpc/Makefile
Normal file
|
@ -0,0 +1,57 @@
|
|||
#
|
||||
# Copyright (C) 2023 Jeffery To
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpc
|
||||
PKG_VERSION:=1.3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=@GNU/mpc/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_HASH:=ab642492f5cf882b74aa0cb730cd410a81edcdbec895183ce930e706c1c759b8
|
||||
|
||||
PKG_LICENSE:=LGPL-3.0-or-later
|
||||
PKG_LICENSE_FILES:=COPYING.LESSER
|
||||
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libmpc
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=GNU MPC library
|
||||
URL:=https://www.multiprecision.org/mpc/
|
||||
DEPENDS:=+libgmp +libmpfr
|
||||
ABI_VERSION:=3
|
||||
endef
|
||||
|
||||
define Package/libmpc/description
|
||||
GNU MPC is a portable library written in C for arbitrary precision
|
||||
arithmetic on complex numbers providing correct rounding. It implements
|
||||
a multiprecision equivalent of the C99 standard. It builds upon the GNU
|
||||
MP and the GNU MPFR libraries.
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/mpc* $(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmpc.{a,so*} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libmpc/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libmpc.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libmpc))
|
22
libs/libmpc/patches/001-only-src.patch
Normal file
22
libs/libmpc/patches/001-only-src.patch
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -23,7 +23,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
# VERSION = @VERSION@@GITVERSION@ # for development version
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SUBDIRS = src tests doc tools
|
||||
+SUBDIRS = src
|
||||
|
||||
EXTRA_HEADERS = src/mpc-log.h
|
||||
include_HEADERS = src/mpc.h @MPC_LOG_H@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -376,7 +376,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
-SUBDIRS = src tests doc tools
|
||||
+SUBDIRS = src
|
||||
EXTRA_HEADERS = src/mpc-log.h
|
||||
include_HEADERS = src/mpc.h @MPC_LOG_H@
|
||||
EXTRA_DIST = doc/fdl-1.3.texi src/mpc-log.h
|
Loading…
Reference in a new issue