collectd: update to 5.10.0
Update collectd to 5.10.0 * leave new plugins as disabled for now (procevent, sysevent) * refresh patches. Remove unenecessary version fix Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
This commit is contained in:
parent
b51d8b252e
commit
4cdc7d1cec
6 changed files with 18 additions and 27 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=collectd
|
PKG_NAME:=collectd
|
||||||
PKG_VERSION:=5.9.2
|
PKG_VERSION:=5.10.0
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://collectd.org/files/ \
|
PKG_SOURCE_URL:=https://collectd.org/files/ \
|
||||||
https://github.com/collectd/collectd/releases/download/collectd-$(PKG_VERSION)
|
https://github.com/collectd/collectd/releases/download/collectd-$(PKG_VERSION)
|
||||||
PKG_HASH:=917c483608b9b38438b121737b510c3d68f335c091bc286aa6ebcc0c8e372a09
|
PKG_HASH:=a03359f563023e744c2dc743008a00a848f4cd506e072621d86b6d8313c0375b
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_REMOVE_FILES:=aclocal.m4 libltdl/aclocal.m4
|
PKG_REMOVE_FILES:=aclocal.m4 libltdl/aclocal.m4
|
||||||
|
@ -82,6 +82,7 @@ COLLECTD_PLUGINS_DISABLED:= \
|
||||||
perl \
|
perl \
|
||||||
pf \
|
pf \
|
||||||
pinba \
|
pinba \
|
||||||
|
procevent \
|
||||||
python \
|
python \
|
||||||
redis \
|
redis \
|
||||||
rrdcached \
|
rrdcached \
|
||||||
|
@ -92,6 +93,7 @@ COLLECTD_PLUGINS_DISABLED:= \
|
||||||
statsd \
|
statsd \
|
||||||
swap \
|
swap \
|
||||||
synproxy \
|
synproxy \
|
||||||
|
sysevent \
|
||||||
tape \
|
tape \
|
||||||
tokyotyrant \
|
tokyotyrant \
|
||||||
turbostat \
|
turbostat \
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/version-gen.sh
|
|
||||||
+++ b/version-gen.sh
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
#!/bin/sh
|
|
||||||
|
|
||||||
-DEFAULT_VERSION="5.9.0.git"
|
|
||||||
+DEFAULT_VERSION="5.9.2"
|
|
||||||
|
|
||||||
if [ -d .git ]; then
|
|
||||||
VERSION="`git describe --dirty=+ --abbrev=7 2> /dev/null | grep collectd | sed -e 's/^collectd-//' -e 's/-/./g'`"
|
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/src/daemon/plugin.c
|
--- a/src/daemon/plugin.c
|
||||||
+++ b/src/daemon/plugin.c
|
+++ b/src/daemon/plugin.c
|
||||||
@@ -1087,7 +1087,7 @@ static int plugin_insert_read(read_func_
|
@@ -1092,7 +1092,7 @@ static int plugin_insert_read(read_func_
|
||||||
int status;
|
int status;
|
||||||
llentry_t *le;
|
llentry_t *le;
|
||||||
|
|
||||||
|
|
|
@ -44,8 +44,8 @@ when --enable-debug configure option is used in Makefile.
|
||||||
while ((loop == 0) && (nanosleep(&ts_wait, &ts_wait) != 0)) {
|
while ((loop == 0) && (nanosleep(&ts_wait, &ts_wait) != 0)) {
|
||||||
if (errno != EINTR) {
|
if (errno != EINTR) {
|
||||||
--- a/src/daemon/plugin.c
|
--- a/src/daemon/plugin.c
|
||||||
+++ a/src/daemon/plugin.c
|
+++ b/src/daemon/plugin.c
|
||||||
@@ -578,10 +578,11 @@
|
@@ -585,10 +585,11 @@ static void *plugin_read_thread(void __a
|
||||||
|
|
||||||
/* Check, if `rf_next_read' is in the past. */
|
/* Check, if `rf_next_read' is in the past. */
|
||||||
if (rf->rf_next_read < now) {
|
if (rf->rf_next_read < now) {
|
||||||
|
|
|
@ -18,7 +18,7 @@ Reversed patch to be applied:
|
||||||
|
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -3393,9 +3393,9 @@ if test "x$with_libmodbus" = "xyes"; the
|
@@ -3389,9 +3389,9 @@ if test "x$with_libmodbus" = "xyes"; the
|
||||||
SAVE_CPPFLAGS="$CPPFLAGS"
|
SAVE_CPPFLAGS="$CPPFLAGS"
|
||||||
CPPFLAGS="$CPPFLAGS $with_libmodbus_cflags"
|
CPPFLAGS="$CPPFLAGS $with_libmodbus_cflags"
|
||||||
|
|
||||||
|
|
|
@ -12,7 +12,7 @@
|
||||||
|
|
||||||
#
|
#
|
||||||
# Checks for typedefs, structures, and compiler characteristics.
|
# Checks for typedefs, structures, and compiler characteristics.
|
||||||
@@ -6394,6 +6399,7 @@ plugin_ipc="no"
|
@@ -6397,6 +6402,7 @@ plugin_ipc="no"
|
||||||
plugin_ipmi="no"
|
plugin_ipmi="no"
|
||||||
plugin_ipvs="no"
|
plugin_ipvs="no"
|
||||||
plugin_irq="no"
|
plugin_irq="no"
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
plugin_load="no"
|
plugin_load="no"
|
||||||
plugin_log_logstash="no"
|
plugin_log_logstash="no"
|
||||||
plugin_mcelog="no"
|
plugin_mcelog="no"
|
||||||
@@ -6828,6 +6834,7 @@ AC_PLUGIN([ipmi], [$plugi
|
@@ -6841,6 +6847,7 @@ AC_PLUGIN([ipmi], [$plugi
|
||||||
AC_PLUGIN([iptables], [$with_libiptc], [IPTables rule counters])
|
AC_PLUGIN([iptables], [$with_libiptc], [IPTables rule counters])
|
||||||
AC_PLUGIN([ipvs], [$plugin_ipvs], [IPVS connection statistics])
|
AC_PLUGIN([ipvs], [$plugin_ipvs], [IPVS connection statistics])
|
||||||
AC_PLUGIN([irq], [$plugin_irq], [IRQ statistics])
|
AC_PLUGIN([irq], [$plugin_irq], [IRQ statistics])
|
||||||
|
@ -28,7 +28,7 @@
|
||||||
AC_PLUGIN([java], [$with_java], [Embed the Java Virtual Machine])
|
AC_PLUGIN([java], [$with_java], [Embed the Java Virtual Machine])
|
||||||
AC_PLUGIN([load], [$plugin_load], [System load])
|
AC_PLUGIN([load], [$plugin_load], [System load])
|
||||||
AC_PLUGIN([log_logstash], [$plugin_log_logstash], [Logstash json_event compatible logging])
|
AC_PLUGIN([log_logstash], [$plugin_log_logstash], [Logstash json_event compatible logging])
|
||||||
@@ -7197,6 +7204,7 @@ AC_MSG_RESULT([ libyajl . . . . . . .
|
@@ -7212,6 +7219,7 @@ AC_MSG_RESULT([ libyajl . . . . . . .
|
||||||
AC_MSG_RESULT([ oracle . . . . . . . $with_oracle])
|
AC_MSG_RESULT([ oracle . . . . . . . $with_oracle])
|
||||||
AC_MSG_RESULT([ protobuf-c . . . . . $have_protoc_c])
|
AC_MSG_RESULT([ protobuf-c . . . . . $have_protoc_c])
|
||||||
AC_MSG_RESULT([ protoc 3 . . . . . . $have_protoc3])
|
AC_MSG_RESULT([ protoc 3 . . . . . . $have_protoc3])
|
||||||
|
@ -36,7 +36,7 @@
|
||||||
AC_MSG_RESULT()
|
AC_MSG_RESULT()
|
||||||
AC_MSG_RESULT([ Features:])
|
AC_MSG_RESULT([ Features:])
|
||||||
AC_MSG_RESULT([ daemon mode . . . . . $enable_daemon])
|
AC_MSG_RESULT([ daemon mode . . . . . $enable_daemon])
|
||||||
@@ -7257,6 +7265,7 @@ AC_MSG_RESULT([ ipmi . . . . . . . .
|
@@ -7274,6 +7282,7 @@ AC_MSG_RESULT([ ipmi . . . . . . . .
|
||||||
AC_MSG_RESULT([ iptables . . . . . . $enable_iptables])
|
AC_MSG_RESULT([ iptables . . . . . . $enable_iptables])
|
||||||
AC_MSG_RESULT([ ipvs . . . . . . . . $enable_ipvs])
|
AC_MSG_RESULT([ ipvs . . . . . . . . $enable_ipvs])
|
||||||
AC_MSG_RESULT([ irq . . . . . . . . . $enable_irq])
|
AC_MSG_RESULT([ irq . . . . . . . . . $enable_irq])
|
||||||
|
@ -46,7 +46,7 @@
|
||||||
AC_MSG_RESULT([ logfile . . . . . . . $enable_logfile])
|
AC_MSG_RESULT([ logfile . . . . . . . $enable_logfile])
|
||||||
--- a/src/collectd.conf.in
|
--- a/src/collectd.conf.in
|
||||||
+++ b/src/collectd.conf.in
|
+++ b/src/collectd.conf.in
|
||||||
@@ -138,6 +138,7 @@
|
@@ -140,6 +140,7 @@
|
||||||
#@BUILD_PLUGIN_IPTABLES_TRUE@LoadPlugin iptables
|
#@BUILD_PLUGIN_IPTABLES_TRUE@LoadPlugin iptables
|
||||||
#@BUILD_PLUGIN_IPVS_TRUE@LoadPlugin ipvs
|
#@BUILD_PLUGIN_IPVS_TRUE@LoadPlugin ipvs
|
||||||
#@BUILD_PLUGIN_IRQ_TRUE@LoadPlugin irq
|
#@BUILD_PLUGIN_IRQ_TRUE@LoadPlugin irq
|
||||||
|
@ -54,7 +54,7 @@
|
||||||
#@BUILD_PLUGIN_JAVA_TRUE@LoadPlugin java
|
#@BUILD_PLUGIN_JAVA_TRUE@LoadPlugin java
|
||||||
@BUILD_PLUGIN_LOAD_TRUE@@BUILD_PLUGIN_LOAD_TRUE@LoadPlugin load
|
@BUILD_PLUGIN_LOAD_TRUE@@BUILD_PLUGIN_LOAD_TRUE@LoadPlugin load
|
||||||
#@BUILD_PLUGIN_LPAR_TRUE@LoadPlugin lpar
|
#@BUILD_PLUGIN_LPAR_TRUE@LoadPlugin lpar
|
||||||
@@ -767,6 +768,12 @@
|
@@ -775,6 +776,12 @@
|
||||||
# IgnoreSelected true
|
# IgnoreSelected true
|
||||||
#</Plugin>
|
#</Plugin>
|
||||||
|
|
||||||
|
@ -69,7 +69,7 @@
|
||||||
# JVMArg "-Djava.class.path=@prefix@/share/collectd/java/collectd-api.jar"
|
# JVMArg "-Djava.class.path=@prefix@/share/collectd/java/collectd-api.jar"
|
||||||
--- a/src/collectd.conf.pod
|
--- a/src/collectd.conf.pod
|
||||||
+++ b/src/collectd.conf.pod
|
+++ b/src/collectd.conf.pod
|
||||||
@@ -3803,6 +3803,27 @@ and all other interrupts are collected.
|
@@ -3873,6 +3873,27 @@ and all other interrupts are collected.
|
||||||
|
|
||||||
=back
|
=back
|
||||||
|
|
||||||
|
@ -259,10 +259,10 @@
|
||||||
+stations value:GAUGE:0:256
|
+stations value:GAUGE:0:256
|
||||||
swap value:GAUGE:0:1099511627776
|
swap value:GAUGE:0:1099511627776
|
||||||
swap_io value:DERIVE:0:U
|
swap_io value:DERIVE:0:U
|
||||||
tcp_connections value:GAUGE:0:4294967295
|
sysevent value:GAUGE:0:1
|
||||||
--- a/Makefile.am
|
--- a/Makefile.am
|
||||||
+++ b/Makefile.am
|
+++ b/Makefile.am
|
||||||
@@ -1150,6 +1150,14 @@ irq_la_LDFLAGS = $(PLUGIN_LDFLAGS)
|
@@ -1165,6 +1165,14 @@ irq_la_LDFLAGS = $(PLUGIN_LDFLAGS)
|
||||||
irq_la_LIBADD = libignorelist.la
|
irq_la_LIBADD = libignorelist.la
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue