glib2: update to 2.56.1
Signed-off-by: Peter Wagner <tripolar@gmx.at>
This commit is contained in:
parent
f87ff14dbb
commit
4cc991094c
2 changed files with 8 additions and 8 deletions
|
@ -8,13 +8,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=glib2
|
PKG_NAME:=glib2
|
||||||
PKG_VERSION:=2.56.0
|
PKG_VERSION:=2.56.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||||
PKG_SOURCE_URL:=@GNOME/glib/2.56
|
PKG_SOURCE_URL:=@GNOME/glib/2.56
|
||||||
PKG_HASH:=ecef6e17e97b8d9150d0e8a4b3edee1ac37331213b8a2a87a083deea408a0fc7
|
PKG_HASH:=40ef3f44f2c651c7a31aedee44259809b6f03d3d20be44545cd7d177221c0b8d
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
|
@ -1,17 +1,17 @@
|
||||||
--- a/gio/gthreadedresolver.c
|
--- a/gio/gthreadedresolver.c
|
||||||
+++ b/gio/gthreadedresolver.c
|
+++ b/gio/gthreadedresolver.c
|
||||||
@@ -869,6 +869,8 @@ do_lookup_records (GTask *task,
|
@@ -871,6 +871,8 @@ do_lookup_records (GTask *task,
|
||||||
records = g_resolver_records_from_res_query (lrd->rrname, rrtype, answer->data, len, herr, &error);
|
|
||||||
g_byte_array_free (answer, TRUE);
|
#ifdef HAVE_RES_NQUERY
|
||||||
|
|
||||||
+#ifdef HAVE_RES_NQUERY
|
+#ifdef HAVE_RES_NQUERY
|
||||||
+
|
+
|
||||||
#if defined(HAVE_RES_NDESTROY)
|
#if defined(HAVE_RES_NDESTROY)
|
||||||
res_ndestroy (&res);
|
res_ndestroy (&res);
|
||||||
#elif defined(HAVE_RES_NCLOSE)
|
#elif defined(HAVE_RES_NCLOSE)
|
||||||
@@ -877,6 +879,8 @@ do_lookup_records (GTask *task,
|
@@ -881,6 +883,8 @@ do_lookup_records (GTask *task,
|
||||||
#error "Your platform has res_ninit() but not res_nclose() or res_ndestroy(). Please file a bug at https://bugzilla.gnome.org/enter_bug.cgi?product=glib"
|
|
||||||
#endif
|
#endif /* HAVE_RES_NQUERY */
|
||||||
|
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
|
|
Loading…
Reference in a new issue