Merge pull request #8540 from BKPepe/zabbix
zabbix: update to version 4.0.6
This commit is contained in:
commit
4c6345e51d
3 changed files with 11 additions and 11 deletions
|
@ -8,13 +8,14 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zabbix
|
PKG_NAME:=zabbix
|
||||||
PKG_VERSION:=4.0.3
|
PKG_VERSION:=4.0.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_HASH:=6b3d3b23c72a7af1958dc0938a566be03f0424cb44df5b2a9f487428f32d0463
|
|
||||||
PKG_SOURCE_URL:=@SF/zabbix
|
PKG_SOURCE_URL:=@SF/zabbix
|
||||||
|
PKG_HASH:=2890851b3a4b0f70f69ef754aa0d07070b42440f56d280113a9474bc4ed75e5b
|
||||||
|
|
||||||
|
PKG_MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
|
||||||
PKG_LICENSE:=GPL-2.0
|
PKG_LICENSE:=GPL-2.0
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
PKG_CPE_ID:=cpe:/a:zabbix:zabbix
|
PKG_CPE_ID:=cpe:/a:zabbix:zabbix
|
||||||
|
@ -70,10 +71,9 @@ endef
|
||||||
define Package/zabbix/Default
|
define Package/zabbix/Default
|
||||||
SECTION:=admin
|
SECTION:=admin
|
||||||
CATEGORY:=Administration
|
CATEGORY:=Administration
|
||||||
|
SUBMENU:=zabbix
|
||||||
TITLE:=Zabbix
|
TITLE:=Zabbix
|
||||||
URL:=https://www.zabbix.com/
|
URL:=https://www.zabbix.com/
|
||||||
SUBMENU:=zabbix
|
|
||||||
MAINTAINER:=Etienne CHAMPETIER <champetier.etienne@gmail.com>
|
|
||||||
USERID:=zabbix=53:zabbix=53
|
USERID:=zabbix=53:zabbix=53
|
||||||
DEPENDS += $(ICONV_DEPENDS) +libpcre +zlib +ZABBIX_GNUTLS:libgnutls +ZABBIX_OPENSSL:libopenssl
|
DEPENDS += $(ICONV_DEPENDS) +libpcre +zlib +ZABBIX_GNUTLS:libgnutls +ZABBIX_OPENSSL:libopenssl
|
||||||
endef
|
endef
|
||||||
|
|
|
@ -27,7 +27,7 @@
|
||||||
### Option: LogFileSize
|
### Option: LogFileSize
|
||||||
# Maximum size of log file in MB.
|
# Maximum size of log file in MB.
|
||||||
# 0 - disable automatic log rotation.
|
# 0 - disable automatic log rotation.
|
||||||
@@ -116,6 +113,7 @@ Server=127.0.0.1
|
@@ -117,6 +114,7 @@ Server=127.0.0.1
|
||||||
# Range: 0-100
|
# Range: 0-100
|
||||||
# Default:
|
# Default:
|
||||||
# StartAgents=3
|
# StartAgents=3
|
||||||
|
@ -35,7 +35,7 @@
|
||||||
|
|
||||||
##### Active checks related
|
##### Active checks related
|
||||||
|
|
||||||
@@ -131,8 +129,6 @@ Server=127.0.0.1
|
@@ -132,8 +130,6 @@ Server=127.0.0.1
|
||||||
# Default:
|
# Default:
|
||||||
# ServerActive=
|
# ServerActive=
|
||||||
|
|
||||||
|
@ -44,7 +44,7 @@
|
||||||
### Option: Hostname
|
### Option: Hostname
|
||||||
# Unique, case sensitive hostname.
|
# Unique, case sensitive hostname.
|
||||||
# Required for active checks and must match hostname as configured on the server.
|
# Required for active checks and must match hostname as configured on the server.
|
||||||
@@ -142,8 +138,6 @@ ServerActive=127.0.0.1
|
@@ -143,8 +139,6 @@ ServerActive=127.0.0.1
|
||||||
# Default:
|
# Default:
|
||||||
# Hostname=
|
# Hostname=
|
||||||
|
|
||||||
|
@ -53,7 +53,7 @@
|
||||||
### Option: HostnameItem
|
### Option: HostnameItem
|
||||||
# Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
|
# Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
|
||||||
# Does not support UserParameters or aliases.
|
# Does not support UserParameters or aliases.
|
||||||
@@ -261,8 +255,8 @@ Hostname=Zabbix server
|
@@ -262,8 +256,8 @@ Hostname=Zabbix server
|
||||||
# Include=
|
# Include=
|
||||||
|
|
||||||
# Include=/usr/local/etc/zabbix_agentd.userparams.conf
|
# Include=/usr/local/etc/zabbix_agentd.userparams.conf
|
||||||
|
|
|
@ -1,11 +1,11 @@
|
||||||
--- a/src/libs/zbxcommon/str.c
|
--- a/src/libs/zbxcommon/str.c
|
||||||
+++ b/src/libs/zbxcommon/str.c
|
+++ b/src/libs/zbxcommon/str.c
|
||||||
@@ -52,7 +52,7 @@ static const char help_message_footer[]
|
@@ -54,7 +54,7 @@ static const char help_message_footer[]
|
||||||
void version(void)
|
void version(void)
|
||||||
{
|
{
|
||||||
printf("%s (Zabbix) %s\n", title_message, ZABBIX_VERSION);
|
printf("%s (Zabbix) %s\n", title_message, ZABBIX_VERSION);
|
||||||
- printf("Revision %s %s, compilation time: %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE, __DATE__, __TIME__);
|
- printf("Revision %s %s, compilation time: %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE, __DATE__, __TIME__);
|
||||||
+ printf("Revision %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE);
|
+ printf("Revision %s %s\n\n", ZABBIX_REVISION, ZABBIX_REVDATE);
|
||||||
puts(copyright_message);
|
puts(copyright_message);
|
||||||
}
|
#if defined(HAVE_POLARSSL) || defined(HAVE_GNUTLS) || defined(HAVE_OPENSSL)
|
||||||
|
printf("\n");
|
||||||
|
|
Loading…
Reference in a new issue