From 4bc44e78c04b62fe9b92625bbe858430da8624c8 Mon Sep 17 00:00:00 2001
From: Rosen Penev <rosenp@gmail.com>
Date: Sat, 12 Sep 2020 17:45:45 -0700
Subject: [PATCH] upmpdcli: update to 1.4.14

Removed sort of upstreamed patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 sound/upmpdcli/Makefile                       |  6 +-
 .../upmpdcli/patches/010-libmicrohttpd.patch  | 74 -------------------
 2 files changed, 3 insertions(+), 77 deletions(-)
 delete mode 100644 sound/upmpdcli/patches/010-libmicrohttpd.patch

diff --git a/sound/upmpdcli/Makefile b/sound/upmpdcli/Makefile
index 84a7698ed..560328293 100644
--- a/sound/upmpdcli/Makefile
+++ b/sound/upmpdcli/Makefile
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=upmpdcli
-PKG_VERSION:=1.4.12
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.14
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.lesbonscomptes.com/upmpdcli/downloads
-PKG_HASH:=bffc78c140ad688987894ea5a1e162e6dcbc7dcae7d2cc322a894f5ea2a2f53b
+PKG_HASH:=e3d90dedee6a942acc049324ca81b7f008d217d386a3e2590a2ca5670cc9df05
 
 PKG_MAINTAINER:=Petko Bordjukov <bordjukov@gmail.com>
 PKG_LICENSE:=LGPL-2.1-or-later
diff --git a/sound/upmpdcli/patches/010-libmicrohttpd.patch b/sound/upmpdcli/patches/010-libmicrohttpd.patch
deleted file mode 100644
index f81e1c945..000000000
--- a/sound/upmpdcli/patches/010-libmicrohttpd.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- a/src/mediaserver/cdplugins/streamproxy.cpp
-+++ b/src/mediaserver/cdplugins/streamproxy.cpp
-@@ -155,7 +155,7 @@ public:
-     ~Internal();
-     bool startMHD();
- 
--    int answerConn(
-+    enum MHD_Result answerConn(
-         struct MHD_Connection *connection, const char *url, 
-         const char *method, const char *version, 
-         const char *upload_data, size_t *upload_data_size,
-@@ -202,7 +202,7 @@ StreamProxy::Internal::Internal(int _listenport, UrlTransFunc _urltrans)
- }
- 
- 
--static int answer_to_connection(
-+static enum MHD_Result answer_to_connection(
-     void *cls, struct MHD_Connection *conn, 
-     const char *url, const char *method, const char *version, 
-     const char *upload_data, size_t *upload_data_size,
-@@ -214,7 +214,7 @@ static int answer_to_connection(
-         return internal->answerConn(
-             conn, url, method, version, upload_data, upload_data_size, con_cls);
-     } else {
--        return -1;
-+        return MHD_NO;
-     }
- }
- 
-@@ -238,7 +238,7 @@ static int print_out_key (void *cls, enum MHD_ValueKind kind,
- }
- #endif /* PRINT_KEYS */
- 
--static int mapvalues_cb(void *cls, enum MHD_ValueKind kind, 
-+static enum MHD_Result mapvalues_cb(void *cls, enum MHD_ValueKind kind, 
-                         const char *key, const char *value)
- {
-     unordered_map<string,string> *mp = (unordered_map<string,string> *)cls;
-@@ -307,7 +307,7 @@ static bool processRange(struct MHD_Connection *mhdconn, uint64_t& offset)
-     return true;
- }
- 
--int StreamProxy::Internal::answerConn(
-+enum MHD_Result StreamProxy::Internal::answerConn(
-     struct MHD_Connection *mhdconn, const char *_url,
-     const char *method, const char *version, 
-     const char *upload_data, size_t *upload_data_size,
-@@ -352,7 +352,7 @@ int StreamProxy::Internal::answerConn(
-                 return MHD_NO;
-             }
-             MHD_add_response_header (response, "Location", url.c_str());
--            int ret = MHD_queue_response(mhdconn, 302, response);
-+            enum MHD_Result ret = MHD_queue_response(mhdconn, 302, response);
-             MHD_destroy_response(response);
-             return ret;
-         }
-@@ -393,7 +393,7 @@ int StreamProxy::Internal::answerConn(
-         int code = httpcode ? httpcode : MHD_HTTP_INTERNAL_SERVER_ERROR;
-         struct MHD_Response *response =
-             MHD_create_response_from_buffer(0, 0, MHD_RESPMEM_PERSISTENT);
--        int ret = MHD_queue_response(mhdconn, code, response);
-+        enum MHD_Result ret = MHD_queue_response(mhdconn, code, response);
-         MHD_destroy_response(response);
-         LOGINF("StreamProxy::answerConn (1): return with http code: " <<
-                code << endl);
-@@ -434,7 +434,7 @@ int StreamProxy::Internal::answerConn(
-     if (reader->fetcher->fetchDone(&fetchcode, &httpcode)) {
-         code = httpcode ? httpcode : MHD_HTTP_INTERNAL_SERVER_ERROR;
-     }
--    int ret = MHD_queue_response(mhdconn, code, response);
-+    enum MHD_Result ret = MHD_queue_response(mhdconn, code, response);
-     MHD_destroy_response(response);
-     return ret;
- }