postfix: bump to 3.8.2 release
Bump postfix to 3.8.2 release. Refresh patches and drop patch 502-detect-glibc.patch as it got merged upstream. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
parent
e8914a2a57
commit
4b7d365b86
8 changed files with 16 additions and 28 deletions
|
@ -8,14 +8,14 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postfix
|
||||
PKG_VERSION:=3.5.8
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=3.8.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
https://de.postfix.org/ftpmirror/official/ \
|
||||
http://ftp.porcupine.org/mirrors/postfix-release/official/
|
||||
PKG_HASH:=22582628cf3edc18c5155c9ff44543dd95a9435fb68135d76a99f572cb07456f
|
||||
PKG_HASH:=6790903cdbb5e0e47196691eb9a5f2cf8050262def941e039e6d4bf4043a5e30
|
||||
|
||||
PKG_MAINTAINER:=Denis Shulyaka <Shulyaka@gmail.com>
|
||||
PKG_LICENSE:=IPL-1.0
|
||||
|
|
|
@ -44,7 +44,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|||
#endif
|
||||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -1509,7 +1509,7 @@ extern int setsid(void);
|
||||
@@ -1519,7 +1519,7 @@ extern int setsid(void);
|
||||
#endif
|
||||
|
||||
#ifndef HAS_CLOSEFROM
|
||||
|
@ -53,7 +53,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|||
|
||||
#endif
|
||||
|
||||
@@ -1563,7 +1563,7 @@ typedef int pid_t;
|
||||
@@ -1573,7 +1573,7 @@ typedef int pid_t;
|
||||
|
||||
/*
|
||||
* Clang-style attribute tests.
|
||||
|
@ -62,7 +62,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|||
* XXX Without the unconditional test below, gcc 4.6 will barf on ``elif
|
||||
* defined(__clang__) && __has_attribute(__whatever__)'' with error message
|
||||
* ``missing binary operator before token "("''.
|
||||
@@ -1577,7 +1577,7 @@ typedef int pid_t;
|
||||
@@ -1587,7 +1587,7 @@ typedef int pid_t;
|
||||
* warn for missing initializations and other trouble. However, OPENSTEP4
|
||||
* gcc 2.7.x cannot handle this so we define this only if NORETURN isn't
|
||||
* already defined above.
|
||||
|
@ -71,7 +71,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|||
* Data point: gcc 2.7.2 has __attribute__ (Wietse Venema) but gcc 2.6.3 does
|
||||
* not (Clive Jones). So we'll set the threshold at 2.7.
|
||||
*/
|
||||
@@ -1653,12 +1653,12 @@ typedef int pid_t;
|
||||
@@ -1663,12 +1663,12 @@ typedef int pid_t;
|
||||
* write to output parameters (for example, stat- or scanf-like functions)
|
||||
* or from functions that have other useful side effects (for example,
|
||||
* fseek- or rename-like functions).
|
||||
|
@ -86,7 +86,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|||
* XXX Prepending "(void)" won't shut up GCC. Clang behaves as expected.
|
||||
*/
|
||||
#if ((__GNUC__ == 3 && __GNUC_MINOR__ >= 4) || __GNUC__ > 3)
|
||||
@@ -1747,7 +1747,7 @@ typedef const char *CONST_CHAR_STAR;
|
||||
@@ -1749,7 +1749,7 @@ typedef const char *CONST_CHAR_STAR;
|
||||
* Safety. On some systems, ctype.h misbehaves with non-ASCII or negative
|
||||
* characters. More importantly, Postfix uses the ISXXX() macros to ensure
|
||||
* protocol compliance, so we have to rule out non-ASCII characters.
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/util/dict_db.c
|
||||
+++ b/src/util/dict_db.c
|
||||
@@ -750,8 +750,8 @@ static DICT *dict_db_open(const char *cl
|
||||
@@ -751,8 +751,8 @@ static DICT *dict_db_open(const char *cl
|
||||
msg_fatal("create DB database: %m");
|
||||
if (db == 0)
|
||||
msg_panic("db_create null result");
|
||||
|
@ -9,5 +9,5 @@
|
|||
+// if (type == DB_HASH && db->set_h_nelem(db, DICT_DB_NELM) != 0)
|
||||
+// msg_fatal("set DB hash element count %d: %m", DICT_DB_NELM);
|
||||
db_base_buf = vstring_alloc(100);
|
||||
#if DB_VERSION_MAJOR == 6 || DB_VERSION_MAJOR == 5 || \
|
||||
#if DB_VERSION_MAJOR == 18 || DB_VERSION_MAJOR == 6 || DB_VERSION_MAJOR == 5 || \
|
||||
(DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR > 0)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -760,9 +760,8 @@ extern int initgroups(const char *, int)
|
||||
@@ -774,9 +774,8 @@ extern int initgroups(const char *, int)
|
||||
#define INTERNAL_LOCK MYFLOCK_STYLE_FLOCK
|
||||
#define DEF_MAILBOX_LOCK "fcntl, dotlock" /* RedHat >= 4.x */
|
||||
#define HAS_FSYNC
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/makedefs
|
||||
+++ b/makedefs
|
||||
@@ -215,7 +215,7 @@ error() {
|
||||
@@ -233,7 +233,7 @@ ARFL=rv
|
||||
|
||||
case $# in
|
||||
# Officially supported usage.
|
||||
|
@ -9,7 +9,7 @@
|
|||
RELEASE=`(uname -r) 2>/dev/null`
|
||||
# No ${x%%y} support in Solaris 11 /bin/sh
|
||||
RELEASE_MAJOR=`expr "$RELEASE" : '\([0-9]*\)'` || exit 1
|
||||
@@ -242,6 +242,15 @@ case "$SYSTEM" in
|
||||
@@ -247,6 +247,15 @@ case $# in
|
||||
esac
|
||||
|
||||
case "$SYSTEM.$RELEASE" in
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/src/posttls-finger/posttls-finger.c
|
||||
+++ b/src/posttls-finger/posttls-finger.c
|
||||
@@ -342,6 +342,7 @@
|
||||
@@ -346,6 +346,7 @@
|
||||
#include <sys/un.h>
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -749,7 +749,8 @@ extern int initgroups(const char *, int)
|
||||
/*
|
||||
* LINUX.
|
||||
*/
|
||||
-#if defined(LINUX2) || defined(LINUX3) || defined(LINUX4) || defined(LINUX5)
|
||||
+#if defined(LINUX2) || defined(LINUX3) || defined(LINUX4) || defined(LINUX5) \
|
||||
+ || defined(LINUX6)
|
||||
#define SUPPORTED
|
||||
#define UINT32_TYPE unsigned int
|
||||
#define UINT16_TYPE unsigned short
|
|
@ -1,6 +1,6 @@
|
|||
--- a/conf/main.cf
|
||||
+++ b/conf/main.cf
|
||||
@@ -40,43 +40,8 @@ compatibility_level = 2
|
||||
@@ -44,43 +44,8 @@ compatibility_level = 3.8
|
||||
#
|
||||
#soft_bounce = no
|
||||
|
||||
|
@ -44,7 +44,7 @@
|
|||
# The default_privs parameter specifies the default rights used by
|
||||
# the local delivery agent for delivery to external file or command.
|
||||
# These rights are used in the absence of a recipient user context.
|
||||
@@ -632,45 +597,4 @@ debugger_command =
|
||||
@@ -641,45 +606,4 @@ debugger_command =
|
||||
# -dmS $process_name gdb $daemon_directory/$process_name
|
||||
# $process_id & sleep 1
|
||||
|
||||
|
|
Loading…
Reference in a new issue