openvswitch: remove support for kernel 4.14 and 4.9

Support for kernel 4.14 has been removed in main repo, so drop the
dependencies here as well (and those for even older 4.9).

Also drop a patch that is required only for 4.14 and lower.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
This commit is contained in:
Adrian Schmutzler 2020-09-02 15:03:13 +02:00 committed by Yousong Zhou
parent b37f1a0716
commit 4b65ea569a
2 changed files with 5 additions and 50 deletions

View file

@ -17,7 +17,7 @@ include ./openvswitch.mk
#
PKG_NAME:=openvswitch
PKG_VERSION:=$(ovs_version)
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
PKG_HASH:=4171e52a8c0ffe160c1daa6687219d902a2a6969b296d223d8dac980ab99a260
@ -77,8 +77,8 @@ ovs_kmod_openvswitch_depends:=\
+IPV6:kmod-nf-nat6 \
+kmod-nf-conntrack \
+IPV6:kmod-nf-conntrack6 \
+(!LINUX_4_9&&!LINUX_4_14):kmod-nsh \
+(!LINUX_4_9&&!LINUX_4_14):kmod-ipt-conntrack-extra \
+kmod-nsh \
+kmod-ipt-conntrack-extra \
ovs_kmod_openvswitch_files:=$(ovs_kmod_upstream_dir)/openvswitch.ko
$(eval $(call OvsKmodPackageTemplate,openvswitch))
@ -103,17 +103,6 @@ $(eval $(call OvsKmodPackageTemplate,openvswitch-geneve))
# NOTE depends
#
# - kmod-gre: with linux-4.14, ovs-2.10, when ovs decides to not
# USE_UPSTREAM_TUNNEL, it requires kmod-gre to be enabled so that
# CONFIG_NET_IPGRE_DEMUX is enabled and ovs will have rpl_gre_init()
# compiled in.
#
# - kmod-gre6: with linux-4.14, ovs-2.10, when ovs decides to not
# USE_UPSTREAM_TUNNEL, it requires xfrm6_tunnel_register() from
# net/ipv6/tunnel6.ko, which will be pulled in by kmod-ip6-tunnel, which
# will be pulled in by kmod-gre6. NOTE that tunnel6.ko itself cannot be
# enabled and selected on its own
#
# - kmod-ipt-conntrack-extra: required for nf_conncount.ko
#
ovs_kmod_openvswitch-intree_title:=Open vSwitch kernel datapath (in tree)
@ -122,11 +111,8 @@ ovs_kmod_openvswitch-intree_depends:=\
+kmod-nf-nat \
+IPV6:kmod-nf-nat6 \
+kmod-nf-conntrack \
+(IPV6&&(LINUX_4_9||LINUX_4_14)):kmod-nf-conntrack6 \
+(LINUX_4_9||LINUX_4_14):kmod-gre \
+(IPV6&&(LINUX_4_9||LINUX_4_14)):kmod-gre6 \
+(!LINUX_4_9&&!LINUX_4_14):kmod-udptunnel4 \
+(!LINUX_4_9&&!LINUX_4_14):kmod-ipt-conntrack-extra \
+kmod-udptunnel4 \
+kmod-ipt-conntrack-extra \
ovs_kmod_openvswitch-intree_files:= $(ovs_kmod_intree_dir)/openvswitch.ko
$(eval $(call OvsKmodPackageTemplate,openvswitch-intree))

View file

@ -1,31 +0,0 @@
From 2939a31ad57f81556afdf5112ee1d68bd2e3f012 Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Mon, 16 Mar 2020 15:18:16 +0800
Subject: [PATCH] datapath: unexport LDFLAGS
OpenWrt build system will put "-specs=.../hardened-pie-ld.specs" into
LDFLAGS when building PIE binaries. However the "-specs" argument is
inteneded for "gcc" the driver while "ld" the linker when presented will
complain it as unrecognized error.
This can cause Kbuild error when building datapath kernel modules. The
issue should only happen when compiling against upstream kernel 4.14 and
earlier. Later ones should have been fixed with kernel upstream commit
d503ac531a5 ("kbuild: rename LDFLAGS to KBUILD_LDFLAGS")
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
datapath/linux/Makefile.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/datapath/linux/Makefile.in b/datapath/linux/Makefile.in
index efc1663e4..61fcaa67e 100644
--- a/datapath/linux/Makefile.in
+++ b/datapath/linux/Makefile.in
@@ -1,5 +1,6 @@
ifeq ($(KERNELRELEASE),)
# We're being called directly by running make in this directory.
+unexport LDFLAGS
include Makefile.main
else
# We're being included by the Linux kernel build system