diff --git a/net/openconnect/Makefile b/net/openconnect/Makefile
index 311be632b..ea4f3ab4e 100644
--- a/net/openconnect/Makefile
+++ b/net/openconnect/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openconnect
 PKG_VERSION:=7.08
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/net/openconnect/files/openconnect.sh b/net/openconnect/files/openconnect.sh
index 881baccf1..4fd397894 100755
--- a/net/openconnect/files/openconnect.sh
+++ b/net/openconnect/files/openconnect.sh
@@ -13,7 +13,6 @@ proto_openconnect_init_config() {
 	proto_config_add_string "password2"
 	proto_config_add_string "token_mode"
 	proto_config_add_string "token_secret"
-	proto_config_add_string "interface"
 	proto_config_add_string "os"
 	proto_config_add_string "csd_wrapper"
 	no_device=1
@@ -23,7 +22,7 @@ proto_openconnect_init_config() {
 proto_openconnect_setup() {
 	local config="$1"
 
-	json_get_vars server port username serverhash authgroup password password2 interface token_mode token_secret os csd_wrapper
+	json_get_vars server port username serverhash authgroup password password2 token_mode token_secret os csd_wrapper
 
 	grep -q tun /proc/modules || insmod tun
 	ifname="vpn-$config"