Merge pull request #5579 from pprindeville/update-isc-dhcp-4.4.0
isc-dhcp: update to 4.4.0
This commit is contained in:
commit
4b0ed514de
3 changed files with 15 additions and 36 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=isc-dhcp
|
PKG_NAME:=isc-dhcp
|
||||||
UPSTREAM_NAME:=dhcp
|
UPSTREAM_NAME:=dhcp
|
||||||
PKG_VERSION:=4.3.6
|
PKG_VERSION:=4.4.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -20,7 +20,7 @@ PKG_SOURCE:=$(UPSTREAM_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
||||||
http://ftp.funet.fi/pub/mirrors/ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
http://ftp.funet.fi/pub/mirrors/ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
||||||
http://ftp.iij.ad.jp/pub/network/isc/dhcp/$(PKG_VERSION)
|
http://ftp.iij.ad.jp/pub/network/isc/dhcp/$(PKG_VERSION)
|
||||||
PKG_HASH:=a41eaf6364f1377fe065d35671d9cf82bbbc8f21207819b2b9f33f652aec6f1b
|
PKG_HASH:=4a90be0f22ad81c987f5584661b60a594f1b21c581b82bfba3ae60f89ae44397
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
PKG_FIXUP:=autoreconf
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
@ -29,12 +29,15 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(UPSTREAM_NAME)-$(PKG_
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
DISABLE_NLS:=
|
||||||
|
|
||||||
define Package/isc-dhcp/Default
|
define Package/isc-dhcp/Default
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
SUBMENU:=IP Addresses and Names
|
SUBMENU:=IP Addresses and Names
|
||||||
TITLE:=ISC's DHCP
|
TITLE:=ISC's DHCP
|
||||||
URL:=https://www.isc.org/software/dhcp
|
URL:=https://www.isc.org/software/dhcp
|
||||||
|
DEPENDS:=+zlib
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/isc-dhcp-relay-ipv4
|
define Package/isc-dhcp-relay-ipv4
|
||||||
|
|
|
@ -1,30 +1,9 @@
|
||||||
diff --git a/bind/Makefile.in b/bind/Makefile.in
|
|
||||||
index bd784c6..5950d19 100644
|
|
||||||
--- a/bind/Makefile.in
|
--- a/bind/Makefile.in
|
||||||
+++ b/bind/Makefile.in
|
+++ b/bind/Makefile.in
|
||||||
@@ -85,13 +85,13 @@ bind2:
|
@@ -116,5 +116,6 @@ uninstall-bind: all
|
||||||
echo Bind export libraries already installed ; \
|
|
||||||
else \
|
|
||||||
echo Building BIND Export libraries - this takes some time. ;\
|
|
||||||
- (cd ${bindsrcdir}/lib/export ; \
|
|
||||||
- echo building in `pwd` ; \
|
|
||||||
- MAKE=${GMAKE} ${GMAKE} >> ${binddir}/build.log) ; \
|
|
||||||
+ (cd ${bindsrcdir}/lib/export/dns ; \
|
|
||||||
+ echo building gen using ${BUILD_CC} in `pwd` ; \
|
|
||||||
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen) ; \
|
|
||||||
\
|
|
||||||
echo Installing BIND Export libraries to ${binddir}. ; \
|
|
||||||
(cd ${bindsrcdir}/lib/export ; \
|
|
||||||
- MAKE=${GMAKE} ${GMAKE} install > ${binddir}/install.log) ; \
|
|
||||||
+ $(MAKE) DESTDIR="" install > ${binddir}/build.log) ; \
|
|
||||||
fi
|
|
||||||
|
|
||||||
clean:
|
|
||||||
@@ -100,6 +100,7 @@ clean:
|
|
||||||
|
|
||||||
# Include the following so that this Makefile is happy when the parent
|
# Include the following so that this Makefile is happy when the parent
|
||||||
# tries to use them.
|
# tries to use them.
|
||||||
+install-exec:
|
+install-exec:
|
||||||
|
|
||||||
distdir:
|
check distdir distclean dvi installcheck:
|
||||||
|
|
||||||
|
|
|
@ -1,18 +1,15 @@
|
||||||
--- a/bind/Makefile.in
|
--- a/bind/Makefile.in
|
||||||
+++ b/bind/Makefile.in
|
+++ b/bind/Makefile.in
|
||||||
@@ -63,8 +63,14 @@
|
@@ -56,7 +56,12 @@ bind1:
|
||||||
else \
|
echo Configuring BIND libraries for DHCP. ; \
|
||||||
echo Configuring BIND Export libraries for DHCP. ; \
|
|
||||||
rm -rf ${cleandirs} ${cleanfiles} ; \
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
||||||
- (cd ${bindsrcdir} && \
|
(cd ${bindsrcdir} && \
|
||||||
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
||||||
+ (cd ${bindsrcdir} && export CC=${CROSS_CC} && \
|
+ export CC=${CROSS_CC} && \
|
||||||
+ ./configure --disable-atomic --disable-kqueue \
|
+ ./configure ${bindconfig} --disable-atomic \
|
||||||
|
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
||||||
+ --disable-epoll --disable-devpoll --without-openssl \
|
+ --disable-epoll --disable-devpoll --without-openssl \
|
||||||
+ --without-libxml2 --enable-exportlib \
|
+ --without-libxml2 --disable-threads --without-gssapi \
|
||||||
+ --enable-threads=no \
|
|
||||||
+ --with-export-includedir=${binddir}/include \
|
|
||||||
+ --with-export-libdir=${binddir}/lib --with-gssapi=no \
|
|
||||||
+ --without-randomdev > ${binddir}/configure.log); \
|
+ --without-randomdev > ${binddir}/configure.log); \
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue