Merge pull request #5579 from pprindeville/update-isc-dhcp-4.4.0
isc-dhcp: update to 4.4.0
This commit is contained in:
commit
4b0ed514de
3 changed files with 15 additions and 36 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=isc-dhcp
|
||||
UPSTREAM_NAME:=dhcp
|
||||
PKG_VERSION:=4.3.6
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
|
@ -20,7 +20,7 @@ PKG_SOURCE:=$(UPSTREAM_NAME)-$(PKG_VERSION).tar.gz
|
|||
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
||||
http://ftp.funet.fi/pub/mirrors/ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
|
||||
http://ftp.iij.ad.jp/pub/network/isc/dhcp/$(PKG_VERSION)
|
||||
PKG_HASH:=a41eaf6364f1377fe065d35671d9cf82bbbc8f21207819b2b9f33f652aec6f1b
|
||||
PKG_HASH:=4a90be0f22ad81c987f5584661b60a594f1b21c581b82bfba3ae60f89ae44397
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
@ -29,12 +29,15 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(UPSTREAM_NAME)-$(PKG_
|
|||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
DISABLE_NLS:=
|
||||
|
||||
define Package/isc-dhcp/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=IP Addresses and Names
|
||||
TITLE:=ISC's DHCP
|
||||
URL:=https://www.isc.org/software/dhcp
|
||||
DEPENDS:=+zlib
|
||||
endef
|
||||
|
||||
define Package/isc-dhcp-relay-ipv4
|
||||
|
|
|
@ -1,30 +1,9 @@
|
|||
diff --git a/bind/Makefile.in b/bind/Makefile.in
|
||||
index bd784c6..5950d19 100644
|
||||
--- a/bind/Makefile.in
|
||||
+++ b/bind/Makefile.in
|
||||
@@ -85,13 +85,13 @@ bind2:
|
||||
echo Bind export libraries already installed ; \
|
||||
else \
|
||||
echo Building BIND Export libraries - this takes some time. ;\
|
||||
- (cd ${bindsrcdir}/lib/export ; \
|
||||
- echo building in `pwd` ; \
|
||||
- MAKE=${GMAKE} ${GMAKE} >> ${binddir}/build.log) ; \
|
||||
+ (cd ${bindsrcdir}/lib/export/dns ; \
|
||||
+ echo building gen using ${BUILD_CC} in `pwd` ; \
|
||||
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen) ; \
|
||||
\
|
||||
echo Installing BIND Export libraries to ${binddir}. ; \
|
||||
(cd ${bindsrcdir}/lib/export ; \
|
||||
- MAKE=${GMAKE} ${GMAKE} install > ${binddir}/install.log) ; \
|
||||
+ $(MAKE) DESTDIR="" install > ${binddir}/build.log) ; \
|
||||
fi
|
||||
|
||||
clean:
|
||||
@@ -100,6 +100,7 @@ clean:
|
||||
@@ -116,5 +116,6 @@ uninstall-bind: all
|
||||
|
||||
# Include the following so that this Makefile is happy when the parent
|
||||
# tries to use them.
|
||||
+install-exec:
|
||||
|
||||
distdir:
|
||||
|
||||
check distdir distclean dvi installcheck:
|
||||
|
|
|
@ -1,19 +1,16 @@
|
|||
--- a/bind/Makefile.in
|
||||
+++ b/bind/Makefile.in
|
||||
@@ -63,8 +63,14 @@
|
||||
else \
|
||||
echo Configuring BIND Export libraries for DHCP. ; \
|
||||
@@ -56,7 +56,12 @@ bind1:
|
||||
echo Configuring BIND libraries for DHCP. ; \
|
||||
rm -rf ${cleandirs} ${cleanfiles} ; \
|
||||
- (cd ${bindsrcdir} && \
|
||||
(cd ${bindsrcdir} && \
|
||||
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
||||
+ (cd ${bindsrcdir} && export CC=${CROSS_CC} && \
|
||||
+ ./configure --disable-atomic --disable-kqueue \
|
||||
+ export CC=${CROSS_CC} && \
|
||||
+ ./configure ${bindconfig} --disable-atomic \
|
||||
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
||||
+ --disable-epoll --disable-devpoll --without-openssl \
|
||||
+ --without-libxml2 --enable-exportlib \
|
||||
+ --enable-threads=no \
|
||||
+ --with-export-includedir=${binddir}/include \
|
||||
+ --with-export-libdir=${binddir}/lib --with-gssapi=no \
|
||||
+ --without-randomdev > ${binddir}/configure.log); \
|
||||
+ --without-libxml2 --disable-threads --without-gssapi \
|
||||
+ --without-randomdev > ${binddir}/configure.log); \
|
||||
fi
|
||||
|
||||
atf:
|
||||
|
|
Loading…
Reference in a new issue