bigclown-control-tool: use Python's json lib
From: https://github.com/hardwario/bch-control-tool/pull/5 This is a backport version 0.2.0 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
This commit is contained in:
parent
7cef0bca23
commit
4ae376ea02
2 changed files with 42 additions and 3 deletions
|
@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
PKG_NAME:=bigclown-control-tool
|
||||
PKG_VERSION:=0.2.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PYPI_NAME:=bch
|
||||
PKG_HASH:=4cd73b92757fce7275a4744baed411c867af2e671c521b90d6690b2320851d58
|
||||
|
@ -30,8 +30,7 @@ define Package/bigclown-control-tool
|
|||
+python3-click-log \
|
||||
+python3-paho-mqtt \
|
||||
+python3-pyserial \
|
||||
+python3-yaml \
|
||||
+python3-simplejson
|
||||
+python3-yaml
|
||||
endef
|
||||
|
||||
$(eval $(call Py3Package,bigclown-control-tool))
|
||||
|
|
|
@ -0,0 +1,40 @@
|
|||
--- a/bch.egg-info/requires.txt
|
||||
+++ b/bch.egg-info/requires.txt
|
||||
@@ -3,4 +3,3 @@ click-log>=0.2.1
|
||||
paho-mqtt>=1.0
|
||||
pyserial>=3.0
|
||||
PyYAML>=3.11
|
||||
-simplejson>=3.6.0
|
||||
--- a/bch/cli.py
|
||||
+++ b/bch/cli.py
|
||||
@@ -6,7 +6,7 @@ import sys
|
||||
import logging
|
||||
import click
|
||||
import click_log
|
||||
-import simplejson as json
|
||||
+import json
|
||||
from datetime import datetime
|
||||
import paho.mqtt.client
|
||||
from paho.mqtt.client import topic_matches_sub
|
||||
--- a/bch/mqtt_client.py
|
||||
+++ b/bch/mqtt_client.py
|
||||
@@ -1,7 +1,7 @@
|
||||
import paho.mqtt.client
|
||||
from paho.mqtt.client import topic_matches_sub
|
||||
import logging
|
||||
-import simplejson as json
|
||||
+import json
|
||||
import time
|
||||
|
||||
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
from setuptools import setup, find_packages
|
||||
|
||||
-requirements = ['Click>=6.0', 'click-log>=0.2.1', 'paho-mqtt>=1.0', 'pyserial>=3.0', 'PyYAML>=3.11', 'simplejson>=3.6.0']
|
||||
+requirements = ['Click>=6.0', 'click-log>=0.2.1', 'paho-mqtt>=1.0', 'pyserial>=3.0', 'PyYAML>=3.11']
|
||||
|
||||
setup(
|
||||
name='bch',
|
Loading…
Reference in a new issue