bind: build fix: remove autoconf AR cruft

This patch removes some autoconf goo which is causing bind to use the host's ar
instead the ar from the toolchain.  If they're both elf platforms this is fine,
but it's no good if host is darwin.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>
This commit is contained in:
Lawrence D'Anna 2015-03-27 19:58:12 -07:00
parent a7ec4ae13c
commit 4a02aa766f

View file

@ -0,0 +1,29 @@
--- a/configure.in
+++ b/configure.in
@@ -93,26 +93,11 @@ esac
#
AC_CONFIG_FILES([make/rules make/includes])
-AC_PATH_PROG(AR, ar)
-ARFLAGS="cruv"
-AC_SUBST(AR)
-AC_SUBST(ARFLAGS)
-
# The POSIX ln(1) program. Non-POSIX systems may substitute
# "copy" or something.
LN=ln
AC_SUBST(LN)
-case "$AR" in
- "")
- AC_MSG_ERROR([
-ar program not found. Please fix your PATH to include the directory in
-which ar resides, or set AR in the environment with the full path to ar.
-])
-
- ;;
-esac
-
#
# Etags.
#