sslh: install sslh-select
Signed-off-by: Toni Uhlig <matzeton@googlemail.com>
This commit is contained in:
parent
c1a96acc35
commit
49b85f9b50
3 changed files with 13 additions and 31 deletions
|
@ -30,6 +30,15 @@ define Package/sslh
|
||||||
URL:=https://rutschle.net/tech/sslh/README.html
|
URL:=https://rutschle.net/tech/sslh/README.html
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/sslh/config
|
||||||
|
config SSLH_SELECT
|
||||||
|
bool "Use sslh-select"
|
||||||
|
depends on PACKAGE_sslh
|
||||||
|
help
|
||||||
|
Use sslh-select instead of sslh-fork.
|
||||||
|
default n
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/sslh/conffiles
|
define Package/sslh/conffiles
|
||||||
/etc/config/sslh
|
/etc/config/sslh
|
||||||
/etc/sslh.conf
|
/etc/sslh.conf
|
||||||
|
@ -40,7 +49,11 @@ MAKE_FLAGS += \
|
||||||
|
|
||||||
define Package/sslh/install
|
define Package/sslh/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
ifeq ($(CONFIG_SSLH_SELECT),y)
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh-select $(1)/usr/sbin/sslh
|
||||||
|
else
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh-fork $(1)/usr/sbin/sslh
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sslh-fork $(1)/usr/sbin/sslh
|
||||||
|
endif
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d/
|
$(INSTALL_DIR) $(1)/etc/init.d/
|
||||||
$(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
$(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
||||||
$(INSTALL_DIR) $(1)/etc/config
|
$(INSTALL_DIR) $(1)/etc/config
|
||||||
|
|
|
@ -1,31 +0,0 @@
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -70,7 +70,7 @@ all: sslh $(MAN) echosrv $(CONDITIONAL_T
|
|
||||||
version.h:
|
|
||||||
./genver.sh >version.h
|
|
||||||
|
|
||||||
-sslh: sslh-fork sslh-select
|
|
||||||
+sslh: sslh-fork
|
|
||||||
|
|
||||||
$(OBJS): version.h common.h collection.h sslh-conf.h gap.h
|
|
||||||
|
|
||||||
@@ -81,10 +81,6 @@ sslh-fork: version.h $(OBJS) sslh-fork.o
|
|
||||||
$(CC) $(CFLAGS) $(LDFLAGS) -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
|
|
||||||
#strip sslh-fork
|
|
||||||
|
|
||||||
-sslh-select: version.h $(OBJS) sslh-select.o Makefile
|
|
||||||
- $(CC) $(CFLAGS) $(LDFLAGS) -o sslh-select sslh-select.o $(OBJS) $(LIBS)
|
|
||||||
- #strip sslh-select
|
|
||||||
-
|
|
||||||
systemd-sslh-generator: systemd-sslh-generator.o
|
|
||||||
$(CC) $(CFLAGS) $(LDFLAGS) -o systemd-sslh-generator systemd-sslh-generator.o -lconfig
|
|
||||||
|
|
||||||
@@ -133,7 +129,7 @@ distclean: clean
|
|
||||||
rm -f tags sslh-conf.[ch] echosrv-conf.[ch] cscope.*
|
|
||||||
|
|
||||||
clean:
|
|
||||||
- rm -f sslh-fork sslh-select echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
|
|
||||||
+ rm -f sslh-fork echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
|
|
||||||
|
|
||||||
tags:
|
|
||||||
ctags --globals -T *.[ch]
|
|
Loading…
Reference in a new issue