diff --git a/net/isc-dhcp/Makefile b/net/isc-dhcp/Makefile
index 8db25d841..dbfc798ac 100644
--- a/net/isc-dhcp/Makefile
+++ b/net/isc-dhcp/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=isc-dhcp
 UPSTREAM_NAME:=dhcp
 PKG_VERSION:=4.4.1
-PKG_RELEASE:=15
+PKG_RELEASE:=16
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
diff --git a/net/isc-dhcp/files/dhcpd.init b/net/isc-dhcp/files/dhcpd.init
index 414c17956..06415729e 100755
--- a/net/isc-dhcp/files/dhcpd.init
+++ b/net/isc-dhcp/files/dhcpd.init
@@ -74,6 +74,7 @@ typeof() {
 /^(true|false)$/		{ print "bool\n"; next; }
 /^\d+$/				{ print "integer\n"; next; }
 /^"[^"]*"$/			{ print "string\n"; next; }
+/^[0-9a-fA-F]{2,2}(:[0-9a-fA-F]{2,2})*$/	{ print "string\n"; next; }
 				{ print "other\n"; next; }
 '
 }