python-enum34: update to 1.1.1, omit docs and tests from package
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
This commit is contained in:
parent
98215f762e
commit
488c706d57
2 changed files with 26 additions and 2 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=enum34
|
||||
PKG_VERSION:=1.0.4
|
||||
PKG_VERSION:=1.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/e/enum34
|
||||
PKG_MD5SUM:=ac80f432ac9373e7d162834b264034b6
|
||||
PKG_MD5SUM:=5edaf22a14ec2769fc973a0443bf02d5
|
||||
|
||||
PKG_LICENSE:=BSD-3-Clause
|
||||
PKG_LICENSE_FILES:=enum/LICENSE
|
||||
|
@ -36,6 +36,11 @@ enum34 is the new Python stdlib enum module available in Python 3.4
|
|||
backported for previous versions of Python from 2.4 to 3.3.
|
||||
endef
|
||||
|
||||
define PyPackage/python-enum34/filespec
|
||||
+|$(PYTHON_PKG_DIR)
|
||||
-|$(PYTHON_PKG_DIR)/enum/test_enum.py
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
||||
endef
|
||||
|
|
19
lang/python-enum34/patches/001-omit-docs.patch
Normal file
19
lang/python-enum34/patches/001-omit-docs.patch
Normal file
|
@ -0,0 +1,19 @@
|
|||
diff -Nur a/setup.py b/setup.py
|
||||
--- a/setup.py 2015-11-29 17:31:14.000000000 +0800
|
||||
+++ b/setup.py 2015-12-07 18:39:00.863378684 +0800
|
||||
@@ -13,15 +13,6 @@
|
||||
version='1.1.1',
|
||||
url='https://pypi.python.org/pypi/enum34',
|
||||
packages=['enum'],
|
||||
- package_data={
|
||||
- 'enum' : [
|
||||
- 'LICENSE',
|
||||
- 'README',
|
||||
- 'doc/enum.rst',
|
||||
- 'doc/enum.pdf',
|
||||
- 'test_enum.py',
|
||||
- ]
|
||||
- },
|
||||
license='BSD License',
|
||||
description='Python 3.4 Enum backported to 3.3, 3.2, 3.1, 2.7, 2.6, 2.5, and 2.4',
|
||||
long_description=long_desc,
|
Loading…
Reference in a new issue